summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-20 19:45:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-20 20:21:19 +0100
commit2b66ca6899b8544f0f885ca897940ab77fdf0bae (patch)
tree9ac6f096713680f942e5173b409af1530d5a70da /dev-python/asgiref
parentdev-python/threadpoolctl: Bump to 3.4.0 (diff)
downloadgentoo-2b66ca6899b8544f0f885ca897940ab77fdf0bae.tar.gz
gentoo-2b66ca6899b8544f0f885ca897940ab77fdf0bae.tar.bz2
gentoo-2b66ca6899b8544f0f885ca897940ab77fdf0bae.zip
dev-python/asgiref: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index d686e3ce3a54..7f9aa56962d7 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.7.2.tar.gz 33393 BLAKE2B b5927a141772a2c0bd4c9354692558c766981a2d7b821122eacb7ee6b59aad86925dc2afb179ff9a3823a65cf17faee89bda5560d68a9ae6d82f9ad1cb31d7b2 SHA512 578ccb54e25869ac9bc7bcd59819d4fc056fdb89a27ec3d7c5b74608984c9d18b41f0b281a3a67bf6b56ad85a7009e336bbdd4a76e2b4a0c8a26c0dfef2687a8
+DIST asgiref-3.8.0.tar.gz 34907 BLAKE2B c8c45f0395719fe9dd9e78ba118a1f2311c1e661bfd7beb12845639dc28e6c0d7bef9a83580588facb2d5954417260233cd38643bc0de3e45d8f3655c6207128 SHA512 ef2e442ba684097e19f4f005c6474b4e6544c7902a84fab85c55667e220f5b1dc11b45d71657c457e7809bcb0b9c99446c79a476d46dfe0a7b77a7e59593027a
diff --git a/dev-python/asgiref/asgiref-3.8.0.ebuild b/dev-python/asgiref/asgiref-3.8.0.ebuild
new file mode 100644
index 000000000000..7b91be9aa018
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest