summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 05:34:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 05:34:20 +0200
commit3ac7e01c7ad7290c95660988b225b1371ad613d7 (patch)
treed1bfaa0aa8d83c8d3cba009693e8952ca62f4a89 /dev-python/astroid
parentdev-python/moto: Bump to 4.2.6 (diff)
downloadgentoo-3ac7e01c7ad7290c95660988b225b1371ad613d7.tar.gz
gentoo-3ac7e01c7ad7290c95660988b225b1371ad613d7.tar.bz2
gentoo-3ac7e01c7ad7290c95660988b225b1371ad613d7.zip
dev-python/astroid: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-3.0.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 4430524866e0..0d59c7608e49 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -2,3 +2,4 @@ DIST astroid-2.15.6.gh.tar.gz 462156 BLAKE2B f5df204a0b635d29165da1566afd9259ff2
DIST astroid-2.15.7.gh.tar.gz 462906 BLAKE2B 7a984f9f7c67c2956958b23ee2ca94c1f86284d8a50aaedbe10b9dca887802189cba21f19ee66b394f347f415d61946aaff52e4d0448271edba77b6bd958fa0e SHA512 716665744915d8a635ac124f03ffe6f7aee6bde6d98c238551ea1c6468595d6c327bb2d5605f66e7ba6294ec1b79c85b861034acba8a4584095ba38e24f82ae9
DIST astroid-2.15.8.gh.tar.gz 462922 BLAKE2B 6a4bf0a50333701aab9282ab126fc53d30621d4e7a54796ac93d1db30bc37098d5409f3ffe91ed279bce5866e2e381eafc7f54f18c86aa3a7fc835f0bf844d9a SHA512 d5d008df3e99c036fb38094c416c080745dad640d46e837b07336a23d5a929823b8b884564486600335791a1be0568cbe519b76e6bd3334e72725966af8cc5f5
DIST astroid-3.0.0.gh.tar.gz 461185 BLAKE2B f6b5923f95f23fdc4731b75f5335d7e7ead6aa85b07c5d2a57bf2ce560774a5d85ad0dfba076e4f24bbc7a17050945956291f5a016867bee049913358f8fc3dd SHA512 c1dbc42a35f7eea9bd87bd1c5701086271f8d4974b6b0e45b301f0b1841f4936bff32cd26647d9e9d9a7636017b5930a290ece0a4001b04dcc50e01344b43acb
+DIST astroid-3.0.1.gh.tar.gz 461593 BLAKE2B de3458bcd9ba111020132e89b6e2fdf18b81b82cba68c986e84af91c910e6c70e7d13ff024b7947f3fa08e2491ba211a77a35421b3d5cd184b94e6a833c0da42 SHA512 2c8a4cf22959aef1eb9510430bcc55d00fcda76d022575786c9a59c093fe4196b67c0b9401f9226595a4cbf1fb9444bdfbb9ac2d83c115ec1d7d46cb7dd75dbd
diff --git a/dev-python/astroid/astroid-3.0.1.ebuild b/dev-python/astroid/astroid-3.0.1.ebuild
new file mode 100644
index 000000000000..02314494f80f
--- /dev/null
+++ b/dev-python/astroid/astroid-3.0.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+# tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+# # some problem with warnings (our options?)
+# tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+# tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+# tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+# # requires six bundled in urllib3, sigh
+# tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+# # requires pip, and looks suspicious anyway
+# tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ # pydantic-2?
+ tests/brain/test_dataclasses.py::test_pydantic_field
+# # TODO
+# tests/test_manager.py::ClearCacheTest::test_clear_cache_clears_other_lru_caches
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}