summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-29 10:27:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-29 10:33:14 -0700
commit5a736b8f57e01d58e28a3dd05b55939a7d61a298 (patch)
tree20c091b571951cf1c98a974ba877b1e7093575fa /dev-python/boto
parentsci-geosciences/routino: bump to 3.3.2 (diff)
downloadgentoo-5a736b8f57e01d58e28a3dd05b55939a7d61a298.tar.gz
gentoo-5a736b8f57e01d58e28a3dd05b55939a7d61a298.tar.bz2
gentoo-5a736b8f57e01d58e28a3dd05b55939a7d61a298.zip
dev-python/boto-2.49.0-r1: revbump, modernize a bit, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/boto-2.49.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/boto/boto-2.49.0-r1.ebuild b/dev-python/boto/boto-2.49.0-r1.ebuild
new file mode 100644
index 000000000000..7bc0f11b0faf
--- /dev/null
+++ b/dev-python/boto/boto-2.49.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT+=" test"
+
+python_test() {
+ "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+}