summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 06:29:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 06:29:42 +0200
commit74d3ad8c23f6fb71a9d96df3258b294b94efe071 (patch)
tree64ef966416e55e1679be67f6f9b61d2d7a5cb2f4 /dev-python/botocore
parentgui-apps/wcm: Stabilize 0.7.5 amd64, #903797 (diff)
downloadgentoo-74d3ad8c23f6fb71a9d96df3258b294b94efe071.tar.gz
gentoo-74d3ad8c23f6fb71a9d96df3258b294b94efe071.tar.bz2
gentoo-74d3ad8c23f6fb71a9d96df3258b294b94efe071.zip
dev-python/botocore: Bump to 1.29.106
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.106.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 78eeb6a7caaa..7abd8f7b00a6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,6 +4,7 @@ DIST botocore-1.29.102.gh.tar.gz 11312537 BLAKE2B 6e5ac46612a692c72c7b9f3587d651
DIST botocore-1.29.103.gh.tar.gz 11356652 BLAKE2B 4b583e094c1dce78257c7a21a1b1bb5fb5705af71f6fbd5215d34bc5dc745d47d19ec2ee4e667d9430f366385aaa45e4c2b139102c1c9de129b06ecb37338bda SHA512 a430fad7d729853d0ea405e772d482e6c9db60e6f580f51ddcec87816e13aa3f7ddded9bf8ce288c84c0e28f2b4b29922b1af9a0a8934123f17bc351a267a6c7
DIST botocore-1.29.104.gh.tar.gz 11360726 BLAKE2B f051024952f137e42a544d60cefbcf4f359a4b68bfad332060703db6e04ff448b6b501541bc1d372aa6d9f30be6931110a02b40505d3fb2de77560bddc0e0d88 SHA512 c97b01240c5502a94d9afaea061e47155efb8a9c11f86778ef3c1595f40cf24f600116a5728025df3af6ed3466115fb94a046dc2e0fb2ed47a1233ffa0def027
DIST botocore-1.29.105.gh.tar.gz 11363053 BLAKE2B 50cdf2f1c2bc60441e3083737509415355a80604f99de8c89026c743750570af3c9571c62d9d9469ccee6934c1fbf169656510da10be69e1360f7e1456cebc68 SHA512 ea68dcf04d006c7324c412ca8f664aa76020f32483fc4e9842a2eed3be7db42f0e13dca60517b372b09f18ffbbf9ba9de78a19e3713c79a1fcd46babe10fd078
+DIST botocore-1.29.106.gh.tar.gz 11366047 BLAKE2B 95bacc0bfd436c86934f7287b6b8729ef0b28ba38a0ddddb0f81a7b57893f795153ba72466de377899234daaeb71921661fd4d8c9fe395b761859ccb0eb59577 SHA512 aaad7d0c863a09bef710214230835f8f3b8eb5f2142268dc30b351446c64cf499054f6297c165a0fb28bbd3db1e784a7a5234279dba711ae02359cfcbbfd8746
DIST botocore-1.29.89.gh.tar.gz 11227280 BLAKE2B 41a1243972e591ea23fb2eebaa5b5fb9547bbd8ccd72fc907c487fd56ebf90d8120ceee472e34a29cd2b036926bc93bda33b564b1b7083e8984daf366eced1f8 SHA512 356298fd3be39957dd60e6268cfd2652998e62950b9060e0774c68e158506dcfea8188059b588c08f520617af38b91eb6b71c16b92f7a71f75f33cb73e7786cf
DIST botocore-1.29.94.gh.tar.gz 11242930 BLAKE2B d6abdda0ad69bfa635c2cdccefff5c0feaa27fb1a307d5cacb140ded35c246a52ebbe5657a9317bdc1441939d2bd62d5829b2ecce01c05976f56737f92fc3f62 SHA512 23c1fb835d492f414a0a67ac03e50ea31f6343676c7e6e8649067b11e3213f84eb068562fe5bd9a49ead9e37381ab132ac820d98fa4af805b41eaf53b0f9cb1b
DIST botocore-1.29.99.gh.tar.gz 11285143 BLAKE2B ba594544fb219cec77659cfa48fb6e3a8241b92c911d9983450648ce97652cad7654181637fed8373fe49e33524f63920128afd4ca9c00bce45603b1ab917648 SHA512 319d70412843149aa43c8d7faeff04122d96091081d30c2da0962fadb27104a24cc147fac2c95492aa407b2f8a25ebed9e7d149c29d5d38134d836581c801bdd
diff --git a/dev-python/botocore/botocore-1.29.106.ebuild b/dev-python/botocore/botocore-1.29.106.ebuild
new file mode 100644
index 000000000000..491b6bbc21f2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.106.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}