summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 23:20:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 08:19:10 +0200
commit34eea06ee62c0bf38261ad7ccb4bee58ce1fa160 (patch)
tree44a7e5e8749b9dbe590e5b45b29a3b8b9550ba1e /dev-python/cffi
parentdev-python/cffi: Use PEP517 build (diff)
downloadgentoo-34eea06ee62c0bf38261ad7ccb4bee58ce1fa160.tar.gz
gentoo-34eea06ee62c0bf38261ad7ccb4bee58ce1fa160.tar.bz2
gentoo-34eea06ee62c0bf38261ad7ccb4bee58ce1fa160.zip
dev-python/cffi: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/cffi-1.15.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/cffi/cffi-1.15.0-r1.ebuild b/dev-python/cffi/cffi-1.15.0-r1.ebuild
index 97883557d572..2039fa2bc8f1 100644
--- a/dev-python/cffi/cffi-1.15.0-r1.ebuild
+++ b/dev-python/cffi/cffi-1.15.0-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=7
DISTUTILS_USE_PEP517=setuptools
# DO NOT ADD pypy to PYTHON_COMPAT
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1 toolchain-funcs
@@ -54,10 +54,17 @@ src_configure() {
}
python_test() {
+ local EPYTEST_DESELECT=()
local EPYTEST_IGNORE=(
# these tests call pip
testing/cffi0/test_zintegration.py
)
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ # exception printing format has changed
+ c/test_c.py::test_callback_exception
+ )
+ fi
"${EPYTHON}" -c "import _cffi_backend as backend" || die
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1