summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 06:38:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 06:50:35 +0200
commit1bef2a3e356aca7a08078c3ec6697c532f13b951 (patch)
tree39f19a49851830a29d331d96686cd5a2d220ffcd /dev-python/cfn-lint
parentdev-python/stripe: Bump to 10.6.0 (diff)
downloadgentoo-1bef2a3e356aca7a08078c3ec6697c532f13b951.tar.gz
gentoo-1bef2a3e356aca7a08078c3ec6697c532f13b951.tar.bz2
gentoo-1bef2a3e356aca7a08078c3ec6697c532f13b951.zip
dev-python/cfn-lint: Bump to 1.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.9.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 99ea93e326ae..7ab010089f1e 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -4,3 +4,4 @@ DIST cfn_lint-1.8.2.tar.gz 2377269 BLAKE2B 8f4266c6d90f50f614f203a4b34ffc15397c9
DIST cfn_lint-1.9.0.tar.gz 2579663 BLAKE2B e23dff84652fb904073d61fc93b193fae0666bec229749d4bd34921b6186db97c365bc6cb25579f96ad4b29cadfb6c5a98943180a06818337ca3204c1f7c6eb6 SHA512 f8280e6e47834d72c084a1bd5b3fcb6cf96ac6484ae4785a5a86f60f5f6c5386fd7f6edcd5982345ea9e16d309cc5f1d6748f88ca17f3d0e6ef7902891bbf1fa
DIST cfn_lint-1.9.1.tar.gz 2579458 BLAKE2B 263da6ba538d66878e66916d3850f249f03bbf189614c7c3bc3cbe20a82226e6f2ac8a696be6eefc9db018f7cf42f2e761fc671f2176f5ca231064fc25c03b78 SHA512 48794c629c4e84ddb9781546aa0e385634537af3f1239617e9569681a375239cf7a7a6f5095c0a6386b217fcd0b6d1bd3e71d65524ecda8b1d4b6ffdce01fdc9
DIST cfn_lint-1.9.2.tar.gz 2579799 BLAKE2B 726492ade9c88d2031b8395a535638c919bf2a813badbba101ae4e8eae7b838e15b8ba8f661d594bac1388abc01087a007092db58bd148432fe555c92c2fd0b3 SHA512 43180ac412fed4e65558f81a7404f0aa30ebf60b09bebb0c145833742842e2f7a4d9b625fb93dc4017396d09f07443023bc3e1cc7af2b102d051dcf9d78b6a07
+DIST cfn_lint-1.9.3.tar.gz 2562556 BLAKE2B c8816021cfb83e2c0d915cc58e7c099bf8ff0640b0562ddf3a7bcfca250e7d4fa03480ff99b5eef4fb103a77aca9a2b3c5266a30b19cddc899f7c0ccb3ca88d6 SHA512 fd75a60b7249bb3f0865d4a37b70d5f64012879b332dfe240f7d7eddc5ae48674e7372b959dd6964f8d0c028c0b75dc78c25caf0ebb3e5186bb6b2b7004e1212
diff --git a/dev-python/cfn-lint/cfn-lint-1.9.3.ebuild b/dev-python/cfn-lint/cfn-lint-1.9.3.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.9.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}