summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-30 04:28:25 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-30 05:10:32 +0100
commit4d85b1631e59ca64d08c37ba0aab6feba4cc679a (patch)
tree4fb55a0be70c449cda3d50f7932b65c6bed9d025 /dev-python/cfn-lint
parentapp-admin/awscli: Bump to 1.37.9 (diff)
downloadgentoo-4d85b1631e59ca64d08c37ba0aab6feba4cc679a.tar.gz
gentoo-4d85b1631e59ca64d08c37ba0aab6feba4cc679a.tar.bz2
gentoo-4d85b1631e59ca64d08c37ba0aab6feba4cc679a.zip
dev-python/cfn-lint: Bump to 1.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.23.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index d25faae6c0bb..b9a0fca33fa9 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn_lint-1.22.3.tar.gz 2700564 BLAKE2B d1bfed3fda2d5133919396a54257ad484c3c
DIST cfn_lint-1.22.5.tar.gz 2722622 BLAKE2B 147f1ec4543a2e54c6b6652b439ca4dd870aad44532a71bc75564bcb71e1aed0258b0387e3be57ef2c8059343cefaf2fef1af02b9442c37347987c018c9411ef SHA512 772430a958e53b90c529311a6f90602de7c2ced9d86840907a9c1e612f18db456c6678d2de43b3bee2e3498cc71b238e2ab8564238aef4467cc285c52ad3a6dd
DIST cfn_lint-1.22.6.tar.gz 2734354 BLAKE2B cda53c8500de713af87c2ad9a1306869c8305cc26389a3e01403d6df0e1a0d4c4014811135712bfa2af54f6333a25c5687c8d5b9c163f4798b394e29a4644622 SHA512 7fddd9ddde5eca7b68e838535ce8a0a0b4d50807467cecb3c51e78736a0c49f85a81608481b7f89b972222b08530b4f29ae8023bf5cdbd70bc79ec27782e9b11
DIST cfn_lint-1.22.7.tar.gz 2735518 BLAKE2B 4357981083d1a32c6be9194552ddb6d2064d8da59b869d617f0047833386232e7fbfede778ad5949a1a10708a1ea166c6bcdfecbaac0e4684e209c812fbde564 SHA512 c079f0b3f7947545ad79d8700833fca1ddc74bc9a224604ced3ab09981e6c363f73a6b214981fbdc16264611213d9a8a41e960de077943a4c407c79af458c551
+DIST cfn_lint-1.23.0.tar.gz 2670666 BLAKE2B 20fe7436223400c390a94448c6bbcf7f6dccaad31f0e91ba362d0b149a8d3837458625e10e1bd4d3e78f9b00b888edd27ed91357f488556aac5497f2942a9dd9 SHA512 914c504934268a7ae13ffdfcb36a461aa9697df95f8409a76008a499b1bb201ca58bc0a0256dc327392f5aac9eb5039511faaf65461521c29a1be081151d589b
diff --git a/dev-python/cfn-lint/cfn-lint-1.23.0.ebuild b/dev-python/cfn-lint/cfn-lint-1.23.0.ebuild
new file mode 100644
index 000000000000..11b35b918d51
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.23.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.94.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}