summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 20:36:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 20:41:37 +0200
commitfba0867450324f5a3bd9e68fe575f4897d4ddd53 (patch)
tree3ca6a75b53ddcf38a584e85cd230d36841233c92 /dev-python/clang-python
parentsys-devel/clang: Add 12.0.0.9999 for master branch (diff)
downloadgentoo-fba0867450324f5a3bd9e68fe575f4897d4ddd53.tar.gz
gentoo-fba0867450324f5a3bd9e68fe575f4897d4ddd53.tar.bz2
gentoo-fba0867450324f5a3bd9e68fe575f4897d4ddd53.zip
dev-python/clang-python: Add 12.0.0.9999 for master branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-12.0.0.9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-12.0.0.9999.ebuild b/dev-python/clang-python/clang-python-12.0.0.9999.ebuild
new file mode 100644
index 000000000000..6d7cb294e651
--- /dev/null
+++ b/dev-python/clang-python/clang-python-12.0.0.9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}