summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 08:43:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:55:24 +0200
commit8b600a3faf9ce979b41a05ef66ff8f9c027572c3 (patch)
tree1807a9e68ba574c87639c51a407d58f3f2c732d8 /dev-python/click-threading
parentdev-python/click-log: Enable py3.11 (diff)
downloadgentoo-8b600a3faf9ce979b41a05ef66ff8f9c027572c3.tar.gz
gentoo-8b600a3faf9ce979b41a05ef66ff8f9c027572c3.tar.bz2
gentoo-8b600a3faf9ce979b41a05ef66ff8f9c027572c3.zip
dev-python/click-threading: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click-threading')
-rw-r--r--dev-python/click-threading/click-threading-0.5.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/click-threading/click-threading-0.5.0-r1.ebuild b/dev-python/click-threading/click-threading-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..a3dc02543cc4
--- /dev/null
+++ b/dev-python/click-threading/click-threading-0.5.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Multithreaded Click apps made easy"
+HOMEPAGE="
+ https://github.com/click-contrib/click-threading/
+ https://pypi.org/project/click-threading/
+"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest