summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-24 22:11:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-24 23:10:28 +0200
commit3e8002ff85bff8975f3beb446ea3e1bb7ef43144 (patch)
tree0122c5d7d0bc39756dbf24be063ff00a759c52a8 /dev-python/colour
parentsys-firmware/ipxe: drop 1.0.0_p20180211, 1.0.0_p20190728, EAPI-6-- (diff)
downloadgentoo-3e8002ff85bff8975f3beb446ea3e1bb7ef43144.tar.gz
gentoo-3e8002ff85bff8975f3beb446ea3e1bb7ef43144.tar.bz2
gentoo-3e8002ff85bff8975f3beb446ea3e1bb7ef43144.zip
dev-python/colour: new package; add version 0.1.5
for sys-apps/polychromatic Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/colour')
-rw-r--r--dev-python/colour/Manifest1
-rw-r--r--dev-python/colour/colour-0.1.5.ebuild25
-rw-r--r--dev-python/colour/files/colour-setup.patch8
-rw-r--r--dev-python/colour/metadata.xml24
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/colour/Manifest b/dev-python/colour/Manifest
new file mode 100644
index 000000000000..137909571b6b
--- /dev/null
+++ b/dev-python/colour/Manifest
@@ -0,0 +1 @@
+DIST colour-0.1.5.tar.gz 24776 BLAKE2B 71e2b44c6379f73fa1a70781ae2559e37122e2db982d1f98ab5c4432b4e95a2c60d6489a88025499c36d288f3e9269e65caf9560d7772e2c1c050266c284816f SHA512 09a5160862bf10cd5f4a94e43c63d6f2a5db43bcaae0e9d8f66900113ec04471e22d0bec7412f0289c6f1e6871c1a544f5be36266aa8d6fd5ec274bd461d9df8
diff --git a/dev-python/colour/colour-0.1.5.ebuild b/dev-python/colour/colour-0.1.5.ebuild
new file mode 100644
index 000000000000..210b23fa944c
--- /dev/null
+++ b/dev-python/colour/colour-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python color representations manipulation library"
+HOMEPAGE="https://github.com/vaab/colour/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+src_prepare() {
+ rm setup.cfg || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/colour/files/colour-setup.patch b/dev-python/colour/files/colour-setup.patch
new file mode 100644
index 000000000000..833a045fbf82
--- /dev/null
+++ b/dev-python/colour/files/colour-setup.patch
@@ -0,0 +1,8 @@
+--- a/setup.py
++++ b/setup.py
+@@ -60,5 +60,4 @@ if "0.1.5".startswith("%%"):
+
+ setup(
+ extras_require={'test': ['nose', ]},
+- d2to1=True
+ )
diff --git a/dev-python/colour/metadata.xml b/dev-python/colour/metadata.xml
new file mode 100644
index 000000000000..044ffd6b7fa3
--- /dev/null
+++ b/dev-python/colour/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Converts and manipulates common color representation (RGB, HSL, web, ...).
+ Full conversion between RGB, HSL, 6-digit hex, 3-digit hex, human color.
+ One object (Color) or bunch of single purpose function (rgb2hex, hsl2rgb
+ ...). Web format that use the smallest representation between 6-digit (e.g.
+ #fa3b2c), 3-digit (e.g. #fbb), fully spelled color (e.g. white), following
+ W3C color naming for compatible CSS or HTML color specifications. Smooth
+ intuitive color scale generation choosing N color gradients. Can pick
+ colors for you to identify objects of your application.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <remote-id type="github">vaab/colour</remote-id>
+ <remote-id type="pypi">colour</remote-id>
+ </upstream>
+</pkgmetadata>