summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-18 08:21:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-18 08:27:26 +0100
commit171a655107499359a49951c1979e1de637de0ea0 (patch)
tree0f622f6d7ccaf3727a330385b263f6de51c37372 /dev-python/croniter
parentdev-python/inline-snapshot: Bump to 0.17.1 (diff)
downloadgentoo-171a655107499359a49951c1979e1de637de0ea0.tar.gz
gentoo-171a655107499359a49951c1979e1de637de0ea0.tar.bz2
gentoo-171a655107499359a49951c1979e1de637de0ea0.zip
dev-python/croniter: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/croniter')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-6.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index ae00d56c2133..ce8e7cb7b126 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1 +1,2 @@
DIST croniter-5.0.1.tar.gz 57084 BLAKE2B 5417d548c103dca87e9dff2ad521e82d5cb468332f3dc11bdff74f331ea23f49753cc9135b22ab1c269e8aa96a05dc04e9b92269b5bbb7334688143daad4664b SHA512 410a3b0ada979259bcd9b82d1b83f3384714645bae642ffaf9e118d65417b716b0efaa3a8c592cc3cc8a9a2694d6f70aa8d36af83aab0c8461493ce96f457bbb
+DIST croniter-6.0.0.tar.gz 64481 BLAKE2B 912932b2919cf8b9d1ed027965ffa0225c29960c3373c40917a32c7a51b1f4f7074791e58c8ee18e301d5e48efc2e6a743d3d294a49ee2bddd5a28ed8ac45755 SHA512 189afd46439471be6f98e477f4a180c56de5b1640463de7a20a3a6c5ff36c121638183d4297be47bfd7fc33a4c38689c9f0d3578010117cf954043638d6a8fe4
diff --git a/dev-python/croniter/croniter-6.0.0.ebuild b/dev-python/croniter/croniter-6.0.0.ebuild
new file mode 100644
index 000000000000..678616a1506d
--- /dev/null
+++ b/dev-python/croniter/croniter-6.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="
+ https://github.com/kiorky/croniter/
+ https://pypi.org/project/croniter/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest