summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:14:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:45 +0200
commit635002b73b1e7b199ab091c2ac63473e4f05acd9 (patch)
tree46bd2f79e95f7d57260d02f1eefca866bbc1018a /dev-python/csvkit
parentdev-python/pyglet: Bump to 2.0.16 (diff)
downloadgentoo-635002b73b1e7b199ab091c2ac63473e4f05acd9.tar.gz
gentoo-635002b73b1e7b199ab091c2ac63473e4f05acd9.tar.bz2
gentoo-635002b73b1e7b199ab091c2ac63473e4f05acd9.zip
dev-python/csvkit: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/csvkit')
-rw-r--r--dev-python/csvkit/Manifest1
-rw-r--r--dev-python/csvkit/csvkit-2.0.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/csvkit/Manifest b/dev-python/csvkit/Manifest
index f79d57079ce9..ec36856da362 100644
--- a/dev-python/csvkit/Manifest
+++ b/dev-python/csvkit/Manifest
@@ -1 +1,2 @@
DIST csvkit-2.0.0.tar.gz 3818527 BLAKE2B 87976e5ea703fe16daac48b65f1f4132821e212c90c6f25fecc17f7e8e1c3859d3224e9b1ee77f6f5a39263391535e83a388ccbe4a610a96cec6256b64056b77 SHA512 70b1d8977bbeefd3ae4cfc26149d17527f6ad56b16b5a932d930505ac7b272fcb0ed9080eba33c9c60daa347c1e79c95c6b05c8dded2e0ea5a301335d21f8a88
+DIST csvkit-2.0.1.tar.gz 3819039 BLAKE2B c67b20f77cd3cada4b940facf5ee246d37cf07499278293bb97cc62f2950677daf236394118ae8a69bdd8686e309ba178bdc3799fbae5b77ff3df7a9d32d70f8 SHA512 2a7b6887c3042becdacb58db7604518c65f07fac51faae268c769ea233961c3754bbed3581a6756d337e40b62b264f8da518f8dc81cd5d61babbec0c2c9eaf31
diff --git a/dev-python/csvkit/csvkit-2.0.1.ebuild b/dev-python/csvkit/csvkit-2.0.1.ebuild
new file mode 100644
index 000000000000..6dec2fc35ed9
--- /dev/null
+++ b/dev-python/csvkit/csvkit-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A suite of utilities for converting to and working with CSV"
+HOMEPAGE="
+ https://github.com/wireservice/csvkit/
+ https://pypi.org/project/csvkit/
+"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/agate-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/agate-excel-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/agate-dbf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/agate-sql-0.5.3[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails depending on locale, let's not force en_US
+ tests/test_utilities/test_csvstat.py::TestCSVStat::test_decimal_format
+ )
+ local -x LC_ALL=C.UTF-8
+ epytest
+}