summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-19 06:27:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-19 06:57:49 +0200
commit38f23810206589ce6a87f6dcc7e00232ee42cd25 (patch)
treed97da45fc9fa4b888fa39ed0082e2475fcba98cd /dev-python/django-timezone-field
parentdev-python/pyparsing: Bump to 3.1.0 (diff)
downloadgentoo-38f23810206589ce6a87f6dcc7e00232ee42cd25.tar.gz
gentoo-38f23810206589ce6a87f6dcc7e00232ee42cd25.tar.bz2
gentoo-38f23810206589ce6a87f6dcc7e00232ee42cd25.zip
dev-python/django-timezone-field: Bump to 5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-5.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 4e11b40d9fea..9ec7892b87af 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1 +1,2 @@
DIST django-timezone-field-5.0.gh.tar.gz 33265 BLAKE2B 1d6c12ff6854463070dd6a5019cc2bfaf9514e5f6568057c684c7b061d28cc99416bac2796474fd2d884cd382e2c0e0a77883c35d4f7a7d2bb77a79255379268 SHA512 6fba9333463f1d68c0d5c6c85ad32b0106fa66be38c4e07e802222f25a0d0e024a77f36b17cb2644e89b76ea50ed667a324a9583b7b5dc0be7518ffa593335f8
+DIST django-timezone-field-5.1.gh.tar.gz 37449 BLAKE2B 9676bd686f7a1bfb2d7e5ee53db5ca3818a9bc20c4c759c09c6d602bcb1937098c40b9c07b3db1d7ca8af2f8882d6aaa333f325e422725e3ea7303fc60e9b59c SHA512 518e16b092af00edae9b2488fd4e9380a661864e9f2d2d3ed8ffc6d9188831d4a7b79ed81d553bc41089ac8cb6fab760339af668ce7c2c0218d991b77306c50f
diff --git a/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild b/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild
new file mode 100644
index 000000000000..e445e9112a8e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/django-5[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}