summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 09:56:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 10:08:01 +0100
commit9ada9a8813df65e4a734be118ff94d9149777402 (patch)
treefe810bbcdb261c5ee1c459bcbd97e6657cdcf229 /dev-python/django-timezone-field
parentdev-python/pdm-pep517: Bump to 0.11.0 (diff)
downloadgentoo-9ada9a8813df65e4a734be118ff94d9149777402.tar.gz
gentoo-9ada9a8813df65e4a734be118ff94d9149777402.tar.bz2
gentoo-9ada9a8813df65e4a734be118ff94d9149777402.zip
dev-python/django-timezone-field: Bump to 5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-5.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 9f4d4cd4679b..46086f68710a 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,2 +1,3 @@
DIST django-timezone-field-4.2.1.gh.tar.gz 23457 BLAKE2B 72452a21e6e086363da2ef40389d12b79860f66706e54fb9050ffe48f7fa6ad2908c75d4c7e17a79df339eac76492599dd4533ddca69a5b8757b46a36ed4b0fc SHA512 4c2da420c3aaffa23d8cdb66dbbe4b2ea8638de5a45d9e381bf9af980e52eba77fc03a2b8fee8497662199cdc9436d56543c0f6316e74ae5da68187a305c34a2
DIST django-timezone-field-4.2.3.gh.tar.gz 23605 BLAKE2B d183fb57254a6a1c86ca57558b88d5429d1d4d368c2cbf2f7a7f4d5414432fd80c5ae1df30793da185d5347afe8535dd821e7e605fb0693f26619b319894a6a3 SHA512 1a72ee557b5b527d2aeae9033c765272ebdd017d9e05708734e9bcdf6355e2747e1ce920a542dbead2d8fc6043024ece24adb3b27ccd6d0f2c8e5b3eb907e012
+DIST django-timezone-field-5.0.gh.tar.gz 33265 BLAKE2B 1d6c12ff6854463070dd6a5019cc2bfaf9514e5f6568057c684c7b061d28cc99416bac2796474fd2d884cd382e2c0e0a77883c35d4f7a7d2bb77a79255379268 SHA512 6fba9333463f1d68c0d5c6c85ad32b0106fa66be38c4e07e802222f25a0d0e024a77f36b17cb2644e89b76ea50ed667a324a9583b7b5dc0be7518ffa593335f8
diff --git a/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild
new file mode 100644
index 000000000000..10674e933208
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}