summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-07 07:06:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-07 07:32:55 +0100
commit1509014657c71ee3c954f89d0d0705a11e3cca81 (patch)
tree4bd8c2aafb73e9a881eead14f446863f751d1f52 /dev-python/dns-lexicon
parentdev-python/poetry: Bump to 1.8.5 (diff)
downloadgentoo-1509014657c71ee3c954f89d0d0705a11e3cca81.tar.gz
gentoo-1509014657c71ee3c954f89d0d0705a11e3cca81.tar.bz2
gentoo-1509014657c71ee3c954f89d0d0705a11e3cca81.zip
dev-python/dns-lexicon: Bump to 3.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.19.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 0269341b8b83..ccb767b18193 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,2 +1,3 @@
DIST dns-lexicon-3.17.0.gh.tar.gz 6200497 BLAKE2B 8f423d4d44517b3186ec7f5cfc5d1e0560d4c98360f8a9d6caab429e0b0e5abe8ee42545b0d7c4cdaf1e2a6a9af41b095198144fda386a207f4f98c7693bb2ba SHA512 1bc182f5881d6acfac72b84331ba50da1219178d274c92e532ed11e73aa79696681d28a002cd1e23f48590953f48e50b62c2ef2db020a07ecf88547717508c0c
DIST dns-lexicon-3.18.0.gh.tar.gz 6216871 BLAKE2B df41467a253cf56c2dd5c127c431973fc80bdca4c174fe84649227d897d7b4612219ca5dc2ad66ae7dc75f626ddfd32aaa950b5cea699bfbb7f05c9a5bda7f40 SHA512 da2804caeef6cd96eb53f7414833757905afa269f328271fccbdb06d988fb46695a0cb917b8dbdfb66579b01cc98d07de8eb7e1cb132c47d49fe05e2ebe18127
+DIST dns-lexicon-3.19.0.gh.tar.gz 6273456 BLAKE2B e0c47e8657b6c2724b50423359200cadac52434a31cbfd9c628ee5dd5cc3cd8779f4b51bb7522a308df90489f30aeec0a0ee44dcc850e5766d0f6b7d25b617f6 SHA512 4efc8864f073ca895a78eeedaf091f8b19df497caa9d8f759d051ac6e91c34e0798b0f7440cad601da62e4115a9abb596660255a8b02096959bd50411d5768be
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.19.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.19.0.ebuild
new file mode 100644
index 000000000000..f024ccc2bacc
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.19.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ >=dev-python/pyotp-2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+ >=dev-python/tldextract-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.28[${PYTHON_USEDEP}]
+ >=dev-python/zeep-3[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_client.py::test_client_init_when_missing_action_should_fail
+)
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}