summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 18:06:03 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-10-30 00:14:58 +0100
commit90911972e60ac55f788089e36f50db130b5e9bfb (patch)
treec55b4cdbed88ca3e3076ff89bb8d1532a88f74c2 /dev-python/e4u/e4u-0.1_rc5-r1.ebuild
parentdev-libs/spsdeclib: drop old version. (diff)
downloadgentoo-90911972e60ac55f788089e36f50db130b5e9bfb.tar.gz
gentoo-90911972e60ac55f788089e36f50db130b5e9bfb.tar.bz2
gentoo-90911972e60ac55f788089e36f50db130b5e9bfb.zip
dev-python/e4u: bump to EAPI=7.
Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10277 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/e4u/e4u-0.1_rc5-r1.ebuild')
-rw-r--r--dev-python/e4u/e4u-0.1_rc5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/e4u/e4u-0.1_rc5-r1.ebuild b/dev-python/e4u/e4u-0.1_rc5-r1.ebuild
new file mode 100644
index 000000000000..a2a6610f9ab7
--- /dev/null
+++ b/dev-python/e4u/e4u-0.1_rc5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="A library for handling unicode emoji and carrier's emoji"
+HOMEPAGE="https://github.com/lambdalisue/e4u"
+SRC_URI="https://github.com/lambdalisue/e4u/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}"/change-emoji4unicode-url.patch
+ "${FILESDIR}"/initialize-e4u-tests.patch
+)
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ insinto /usr/share/e4u
+ doins e4u/data/emoji4unicode.xml
+
+ distutils-r1_python_install_all
+}