summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 04:57:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:43 +0200
commit21029918bf118fa7bd1fd678fba1238d85f1899f (patch)
tree539e9b2ab17cdca44d4e65e59c3d1766cb57a928 /dev-python/elementpath
parentdev-python/google-auth: Bump to 2.21.0 (diff)
downloadgentoo-21029918bf118fa7bd1fd678fba1238d85f1899f.tar.gz
gentoo-21029918bf118fa7bd1fd678fba1238d85f1899f.tar.bz2
gentoo-21029918bf118fa7bd1fd678fba1238d85f1899f.zip
dev-python/elementpath: Bump to 4.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.1.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 031203876ca5..a88b5733875f 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-4.1.2.tar.gz 320962 BLAKE2B 39ad80033022119159bcc89e6ea06f23de7d6c0cfca7e63f64ac01fa0e4c36a8d3091cc57efdfc7d5efb735ee058d2ed25abd15ae5297b65a8efdfe4413e4ffc SHA512 f6ab5905986fab88398e9a3774460069f610234126649299228f86020bee48f3d98be90434a4f662b371ef0051e80147df0a0f323e7095fedcab8567237c2c00
DIST elementpath-4.1.3.tar.gz 321288 BLAKE2B 70293e5c700b8dde03ad9bcc065daf428289ba08565d5ec0e5df316cbf35b1d40a1216a651d4e41a5c576681e2955d6c298935cb22aa4ed929ffb530e8281216 SHA512 8acd421694cc44ccd70dacb385ca0b9feaac810f4eb9cd79bacc515b92c6b3c11e78c6a077eca4393965ccd112560f62b9666a02dbf79841dd1f4fc54cb04322
+DIST elementpath-4.1.4.tar.gz 321593 BLAKE2B 90b7ec9973acd300660fbe02b787eb5e6e2e2e6405b2337844f18415c48baaa5dd5c94fe90523e7c5090f9840c8cfdb333dd96afbb18e35c9adefda68dbda0ab SHA512 279ca4447b086f47f69e7cecbeb998e949ab6d5772cb5cddf231df8da2eed3a580813b0609758097bc409cbba46a884a3859d604cdf8a956c90503409ab90db2
diff --git a/dev-python/elementpath/elementpath-4.1.4.ebuild b/dev-python/elementpath/elementpath-4.1.4.ebuild
new file mode 100644
index 000000000000..5a131dfbbd75
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}