summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-18 08:50:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-18 09:54:46 +0200
commit73463742fa5033aa6dda64204ab8e792c536be57 (patch)
tree1f4aa19ffe5c6985773b963cc1315e0e6b957acc /dev-python/fastjsonschema
parentdev-python/iminuit: Bump to 2.13.0 (diff)
downloadgentoo-73463742fa5033aa6dda64204ab8e792c536be57.tar.gz
gentoo-73463742fa5033aa6dda64204ab8e792c536be57.tar.bz2
gentoo-73463742fa5033aa6dda64204ab8e792c536be57.zip
dev-python/fastjsonschema: Bump to 2.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.16.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 3de513fa8101..979f56e24621 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST python-fastjsonschema-2.15.3.tar.gz 389350 BLAKE2B f9ab32666fce1ba44a11cb981f4f301d7d55260767ec71aefa54ad6bcdd5b8c3d246656908dcd50e909257b35bb9ee24eb34d5ce7fe0f91501127cad412a7e1d SHA512 59dfc513de46e9df790edaa1abc994decdf98d65bec8eb8a6ac7211d2277f4e15d521a308e45c6532a232321d8a4655f87b7a01f2d57b9de20246a4d6deeeb9b
+DIST python-fastjsonschema-2.16.1.gh.tar.gz 391733 BLAKE2B 7d53b51ad88fb6e11226510f3dc7f7ef8ca2d6e22825e31f32fe7b9343c2d7bf946c0d528ecdb9550abd5e5dd01f2bf52d6670fa644eb4b453f2a45080cd9318 SHA512 b3ef41926ec6a54d527f68f6c198fdc61fc6528449137557a3f2130c5d01914a6ea3300bc6efb90f9b8fefbb98464760378108ef221dcb021414b2e0ffb1eb73
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.16.1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.16.1.ebuild
new file mode 100644
index 000000000000..4d2f3bd44cd4
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.16.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}