summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 16:00:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 16:04:18 +0200
commit1b88b4401cfdadf4e0267bec28ff59a70b68d7ba (patch)
treeb59c385d37a7ff9e30a31915696d6d2aecc164ef /dev-python/flask-restful
parentdev-python/huawei-lte-api: Add python@ as co-maint. (diff)
downloadgentoo-1b88b4401cfdadf4e0267bec28ff59a70b68d7ba.tar.gz
gentoo-1b88b4401cfdadf4e0267bec28ff59a70b68d7ba.tar.bz2
gentoo-1b88b4401cfdadf4e0267bec28ff59a70b68d7ba.zip
dev-python/flask-restful: Bump to 0.3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/Manifest1
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.9.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
index 57f2e49019e5..3766d56af29d 100644
--- a/dev-python/flask-restful/Manifest
+++ b/dev-python/flask-restful/Manifest
@@ -1 +1,2 @@
DIST flask-restful-0.3.8.tar.gz 114588 BLAKE2B a18eac613300102bb5a5ca78cea1e6f81f3de21d8bd2e6c72f2f1a559e8b4228175cc7d372b68f131267cd8bc759e354e5782e527d1e992579210348cd2b78dd SHA512 15172114fcedc2f4286cf5f583d95e42c8c8ce6553f9a44e57124f2b1417bf9f094dcb5154a6933ebebc8022f39d4d7969d29d38576111f9d5b45f630b36a66c
+DIST flask-restful-0.3.9.gh.tar.gz 118195 BLAKE2B a4f18c3faf06a7c9b628657aafbab4b9492793d9a61ab60a3e4d8112e0fb5e120cff2f2dae87915e44915838572ae0ca1737025ad5f906c2a953afc4b1f49c6f SHA512 34bea8ed6e9de3ad1c2ca63e7af67ed2a175f84c433b08ff643f91d88feda0e3c1c3967deb2fe5ad308b05f373b10c08245edf65ed97a7c5a3683aa900e9edf2
diff --git a/dev-python/flask-restful/flask-restful-0.3.9.ebuild b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
new file mode 100644
index 000000000000..858cb0ca86fc
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="
+ https://flask-restful.readthedocs.io/en/latest/
+ https://github.com/flask-restful/flask-restful/"
+SRC_URI="
+ https://github.com/flask-restful/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+python_install_all() {
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ distutils-r1_python_install_all
+}