summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 15:49:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 15:52:55 +0200
commit0480f3ee549f4444a58d4c6cc193f367584177bd (patch)
tree188854bd60bb0530d12e7afe18a9dbaeb45d510e /dev-python/fs
parentdev-python/pyftpdlib: mark ALLARCHES (diff)
downloadgentoo-0480f3ee549f4444a58d4c6cc193f367584177bd.tar.gz
gentoo-0480f3ee549f4444a58d4c6cc193f367584177bd.tar.bz2
gentoo-0480f3ee549f4444a58d4c6cc193f367584177bd.zip
dev-python/fs: Fix test failures due to pytest-xvfb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.13.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/fs/fs-2.4.13.ebuild b/dev-python/fs/fs-2.4.13.ebuild
index 99833ddeba7d..5ef873151954 100644
--- a/dev-python/fs/fs-2.4.13.ebuild
+++ b/dev-python/fs/fs-2.4.13.ebuild
@@ -39,6 +39,11 @@ BDEPEND="
distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
+python_test() {
+ # pytest-xvfb causes test failures due to a zombie Xvfb process
+ epytest -p no:xvfb
+}
+
pkg_postinst() {
optfeature "S3 support" dev-python/boto
optfeature "SFTP support" dev-python/paramiko