summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 20:31:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 20:34:48 +0100
commit699094f2382747f9249b3ee198ef3f851deb3487 (patch)
tree7831b05ec88c9b15700aef22a0c91c45ca149ce5 /dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild
parentdev-python/genshi: Bump to 0.7.6 (diff)
downloadgentoo-699094f2382747f9249b3ee198ef3f851deb3487.tar.gz
gentoo-699094f2382747f9249b3ee198ef3f851deb3487.tar.bz2
gentoo-699094f2382747f9249b3ee198ef3f851deb3487.zip
dev-python/google-api-python-client: Bump to 2.37.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild
new file mode 100644
index 000000000000..13b520b44abe
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.37.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}