summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-05 09:13:29 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-05 09:13:29 +0200
commit52a61970f1a8780db95fb89219cab66c9a05e7c0 (patch)
tree86627c3ccf5315eb221d8f81280f1c72e3239ffa /dev-python/graph-tool
parentdev-python/graph-tool: Bump to 2.22 (diff)
downloadgentoo-52a61970f1a8780db95fb89219cab66c9a05e7c0.tar.gz
gentoo-52a61970f1a8780db95fb89219cab66c9a05e7c0.tar.bz2
gentoo-52a61970f1a8780db95fb89219cab66c9a05e7c0.zip
dev-python/graph-tool: Update live ebuild
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index f6a94cb3f9b6..cf9f4302985a 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit check-reqs python-r1 toolchain-funcs
@@ -25,11 +25,11 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-libs/boost:=[context,python,${PYTHON_USEDEP}]
dev-libs/expat
dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
- sci-mathematics/cgal
+ >=sci-mathematics/cgal-4.9
cairo? (
dev-cpp/cairomm
dev-python/pycairo[${PYTHON_USEDEP}]
@@ -64,7 +64,6 @@ src_configure() {
configure() {
econf \
--disable-static \
- --disable-optimization \
$(use_enable openmp) \
$(use_enable cairo) \
--with-boost-python="${EPYTHON: -3}${threads}"