summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-08 13:33:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-08 13:35:03 +0100
commit3f97c718845e0444a1113dc9bf4385c083764f8a (patch)
treeb0e2ee400084205e32dac1109fd558b925ac34f3 /dev-python/h5py
parentdev-python/loky: Skip a hanging test (diff)
downloadgentoo-3f97c718845e0444a1113dc9bf4385c083764f8a.tar.gz
gentoo-3f97c718845e0444a1113dc9bf4385c083764f8a.tar.bz2
gentoo-3f97c718845e0444a1113dc9bf4385c083764f8a.zip
dev-python/h5py: Disable setup_requires the easy way
Thanks to Thomas Kluyver for the suggestion. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/h5py-3.2.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/h5py/h5py-3.2.1.ebuild b/dev-python/h5py/h5py-3.2.1.ebuild
index df2504fb79d7..82dc31d6252c 100644
--- a/dev-python/h5py/h5py-3.2.1.ebuild
+++ b/dev-python/h5py/h5py-3.2.1.ebuild
@@ -46,11 +46,11 @@ distutils_enable_sphinx docs \
#}
python_prepare_all() {
- # fix other numpy dep to be >=
- sed -i -e '/numpy/s:==:>=:' setup.py || die
# avoid pytest-mpi dep, we do not use mpi anyway
sed -i -e 's:pytest-mpi::' pytest.ini || die
distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
}
python_test() {