summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/h5py
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest3
-rw-r--r--dev-python/h5py/h5py-2.3.1.ebuild54
-rw-r--r--dev-python/h5py/h5py-2.4.0.ebuild50
-rw-r--r--dev-python/h5py/h5py-2.5.0.ebuild66
-rw-r--r--dev-python/h5py/metadata.xml19
5 files changed, 192 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
new file mode 100644
index 000000000000..ee40b2971898
--- /dev/null
+++ b/dev-python/h5py/Manifest
@@ -0,0 +1,3 @@
+DIST h5py-2.3.1.tar.gz 1072766 SHA256 447e55d5893ca285d1185a938548a12f3f7d4af441f1a7740ac28bc3aecf85c1 SHA512 f0da1d2ac855c02fb828444d719a1b23a580adb049335f3e732ace67558a125ac8cd3b3a68ac6bf9d10aa3ab19e4672b814eb28cc8c66910750c62efb655d744 WHIRLPOOL cdd2be028d450d1566776b056550af001dd382082cce5cac9fdb8968071b9f3e9855e2c30bf12bbb800c1313343980f74c2ad3d853318585bdc6134c8af5b35c
+DIST h5py-2.4.0.tar.gz 172462 SHA256 faaeadf4b8ca14c054b7568842e0d12690de7d5d68af4ecce5d7b8fc104d8e60 SHA512 b341994899d27ceae81cdf920c44902e7db64cd3e613e2b4bcf19a6d0aea5f2fcc4acc946222a6e5d4b03d787b05e2dd2a2a55df99561f74d6e827a61f85b2c5 WHIRLPOOL 734e848437921f97b2169243993cd111d4f91578bce9980ec9d373113917185f47ea8b1d98732a61bbfc7c7ae8bc1481ddf53a6ee576705352b6d77e22263f27
+DIST h5py-2.5.0.tar.gz 684354 SHA256 9833df8a679e108b561670b245bcf9f3a827b10ccb3a5fa1341523852cfac2f6 SHA512 4a83f9ae1855a7fad90133b327d426201c8ccfd2e7fbe9f39b2d61a2eee2f3ebe2ea02cf80f3d4e1ad659f8e790c173df8cc99b87d0b7ce63d34aa88cfdc7939 WHIRLPOOL 7d7852d1d2481077a81dbf194e72da10d013c43ede4d2d6e319e1e2be0f70d7495b0964ea7787ddbd145ac774cdabc32c5b7e51fc7c9bfec429d673b12bcc10b
diff --git a/dev-python/h5py/h5py-2.3.1.ebuild b/dev-python/h5py/h5py-2.3.1.ebuild
new file mode 100644
index 000000000000..0ca6ad8a9fb4
--- /dev/null
+++ b/dev-python/h5py/h5py-2.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test examples mpi"
+
+RDEPEND="
+ sci-libs/hdf5:=[mpi=]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --mpi=$(usex mpi yes no)
+}
+
+python_test() {
+ esetup.py test --mpi=$(usex mpi yes no)
+}
+
+python_install() {
+ distutils-r1_python_install --mpi=$(usex mpi yes no)
+}
+
+python_install_all() {
+ DOCS=( README.rst ANN.rst )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/h5py/h5py-2.4.0.ebuild b/dev-python/h5py/h5py-2.4.0.ebuild
new file mode 100644
index 000000000000..68de84974866
--- /dev/null
+++ b/dev-python/h5py/h5py-2.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test examples mpi"
+
+RDEPEND="
+ sci-libs/hdf5:=[mpi=]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ esetup.py configure $(usex mpi --mpi '')
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ DOCS=( README.rst ANN.rst )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/h5py/h5py-2.5.0.ebuild b/dev-python/h5py/h5py-2.5.0.ebuild
new file mode 100644
index 000000000000..a6218f297931
--- /dev/null
+++ b/dev-python/h5py/h5py-2.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test examples mpi"
+
+RDEPEND="
+ sci-libs/hdf5:=[mpi=]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ )
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ esetup.py configure $(usex mpi --mpi '')
+}
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}"/docs || die
+ sed '/html_theme/s:default:alabaster:g' -i conf.py || die
+ rm -r _build || die
+ emake html
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ DOCS=( README.rst ANN.rst )
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/h5py/metadata.xml b/dev-python/h5py/metadata.xml
new file mode 100644
index 000000000000..7309a3a9f6b0
--- /dev/null
+++ b/dev-python/h5py/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ HDF5 for Python (h5py) is a general-purpose simple Python interface to the
+ Hierarchical Data Format library, version 5. Existing Python and
+ Numpy concepts are used for the interface. Almost all HDF5 features
+ are available from Python, including things like compound datatypes
+ (as used with Numpy recarray types), HDF5 attributes, hyperslab and
+ point-based I/O, and more recent features in HDF 1.8 like resizable
+ datasets and recursive iteration over entire files.
+</longdescription>
+ <upstream>
+ <remote-id type="google-code">h5py</remote-id>
+ <remote-id type="pypi">h5py</remote-id>
+ </upstream>
+</pkgmetadata>