summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-07-10 17:13:55 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-07-10 17:13:55 +0200
commit20b33d8d158f5743fdc940958b1043c5eda1726f (patch)
tree537218a17de0032c349fe9c8caee094e395310f4 /dev-python/hcloud-python
parentapp-admin/hcloud: version bump to 1.17.0 (diff)
downloadgentoo-20b33d8d158f5743fdc940958b1043c5eda1726f.tar.gz
gentoo-20b33d8d158f5743fdc940958b1043c5eda1726f.tar.bz2
gentoo-20b33d8d158f5743fdc940958b1043c5eda1726f.zip
dev-python/hcloud-python: version bump to 1.8.1
Bug: https://bugs.gentoo.org/731838 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.8.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index a17c82a0a4f4..78e5a91758fe 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-python-1.6.3.tar.gz 71575 BLAKE2B a6c969d713d1351bba0cebef8752abbbf0805b4a39eedc918767ccf60d590ac8259e1405a25c2c563923146d52ae1318d6362cbaee311bfe04bea5afcc18951b SHA512 dec3f16197de9f02c2707601e1cad40289d3ccbd6256887da50b84fb8fe6b0fb98f708c9ba0cfc2ff1308a53b9997cfda579df3ec79a1d28686a3c43f4124e74
DIST hcloud-python-1.7.0.tar.gz 71683 BLAKE2B 43dfda161505d9aa486487a028dff9406e77f3c33efe935c13faf19503d1cd98a136703939408b0faf50633c1a40bbd5c43d90a6373acb38e8a0d61bf715a02a SHA512 d8fac8b74862d5f59f50ddac4f675c409f0bb5b51b16c6db094acae2323214c623bdb459c7fe0e74bb21fc88aa61e551b951cfa6c7de4504a4bf31c7f9481f2e
+DIST hcloud-python-1.8.1.tar.gz 87532 BLAKE2B d5e2b5d2aef96508042189d650ef0c6793ca8747a99f20c591c63dbeed497576ef6cf268f75cdc5551b9b3469f1087d5d2ad167af77a93ab321cc9c70d1bb65b SHA512 e26976abe77149db53ea8a35e53de85e0acc3b2021ecbfb1a3a634230d2324e2fb212f54cfcb7a96993b4776d305a247b29aa883053958db881a794f431858bd
diff --git a/dev-python/hcloud-python/hcloud-python-1.8.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.8.1.ebuild
new file mode 100644
index 000000000000..2dab63734047
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-2.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ <dev-python/requests-2.24[${PYTHON_USEDEP}]"
+
+BDEPEND="${COMMON_DEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ <dev-python/future-0.19[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ rm -fr tests/integration
+ default
+}