summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 04:07:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 04:22:20 +0200
commit2d8cd5c10b2034b77ed5ed5d5ea12eaa0541346b (patch)
tree24cdeed670e89e8eb262faf4158ba499c01e4776 /dev-python/identify
parentgames-roguelike/stone-soup: add 0.32.0 (diff)
downloadgentoo-2d8cd5c10b2034b77ed5ed5d5ea12eaa0541346b.tar.gz
gentoo-2d8cd5c10b2034b77ed5ed5d5ea12eaa0541346b.tar.bz2
gentoo-2d8cd5c10b2034b77ed5ed5d5ea12eaa0541346b.zip
dev-python/identify: Bump to 2.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index fe4df73673f7..ff6cc325557a 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.6.0.gh.tar.gz 101732 BLAKE2B 0c6cdd8801861ac2b33c812766008d3e1a689ea09ee698441439aa2c02207f9f05983f7cbbdf1e999cdf4b34a6994a60c12249cf6722b690ae05126bc3178273 SHA512 0e7b27783fc9133d76247811e1bbd92b1c2f54c2feef6a603e725f92af44b8f595a5b39162db3b9f4cebdf2fe58587bb10f9d93a745d5cb6b507892d67c32899
+DIST identify-2.6.1.gh.tar.gz 101751 BLAKE2B 5f957409a4a819ba0922065484c824282255174619630896cd5b708912097bec1662e55eafcf4f6cadf832bb988c824623d9fc1879e76665c096cbcf01ff4097 SHA512 3d7ee7e0e75d24626b4c322eeafaf624dac87692dcb0eef082be6eb413b3dcc8566e356b83c2cd1eea95e98d55258ee5aebd06ac0c85ee385629e819a549d155
diff --git a/dev-python/identify/identify-2.6.1.ebuild b/dev-python/identify/identify-2.6.1.ebuild
new file mode 100644
index 000000000000..6294eec35289
--- /dev/null
+++ b/dev-python/identify/identify-2.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest