summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-26 03:50:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-26 04:09:35 +0200
commit30cb5d3e5e9ba5e348c408fe7f108ffd66fe7341 (patch)
tree4ad2d5994c287b7dab3f519518e393194f7e5482 /dev-python/jsonschema-path
parentdev-python/pygame: Bump to 2.6.0 (diff)
downloadgentoo-30cb5d3e5e9ba5e348c408fe7f108ffd66fe7341.tar.gz
gentoo-30cb5d3e5e9ba5e348c408fe7f108ffd66fe7341.tar.bz2
gentoo-30cb5d3e5e9ba5e348c408fe7f108ffd66fe7341.zip
dev-python/jsonschema-path: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema-path')
-rw-r--r--dev-python/jsonschema-path/Manifest1
-rw-r--r--dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jsonschema-path/Manifest b/dev-python/jsonschema-path/Manifest
index 37d779c809dd..b670c8f0ec9d 100644
--- a/dev-python/jsonschema-path/Manifest
+++ b/dev-python/jsonschema-path/Manifest
@@ -1 +1,2 @@
DIST jsonschema-path-0.3.2.gh.tar.gz 39521 BLAKE2B 871bb33c7839a3b9bf66e145c239cd6715cfaa2ae782f28b77de83228136af5259e1757856e47f0ac26f46572911553510a153f4f48e3b1d2a813160eb65c143 SHA512 e49b32c4609238d2808938976bd0022f86837e9d7d296a137d42f8e8c80d20d20fdd23a07b898063536290b36bd72df0abef64b65997a66cb3fb9c403cc275d3
+DIST jsonschema-path-0.3.3.gh.tar.gz 40104 BLAKE2B 00f3551f807a76ca59d7dca55d28dc86f36f94ad03be52376a67f29936a1215e50dc5d4af33aabe29026913737e9f453d466450122411297f714e3557fe06d2e SHA512 846d476285b4c89d0241d18be09eb7c12df855f7b28f0d3ea9942a9d23977f3c051b93a1281f6f5323c2c4bc9c86fe82b5eae1bce647f58d9d2acce65d4f54a8
diff --git a/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild b/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild
new file mode 100644
index 000000000000..ee7d7a29e156
--- /dev/null
+++ b/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-path/
+ https://github.com/p1c2u/jsonschema-path/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+# requests seem "optional" but they failed at properly making it
+# optional in poetry, sigh
+RDEPEND="
+ >=dev-python/pathable-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ # remove random pins due to caret operator
+ sed -i -e 's:\^:>=:' -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}