summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-29 05:01:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-29 05:18:22 +0100
commit679bcc3c305c04d2f5c880f0ced8ae450b344de7 (patch)
treef3ef33c199cbefd5d83f90698ea35701671691b5 /dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
parentdev-python/urwid: Bump to 2.6.7 (diff)
downloadgentoo-679bcc3c305c04d2f5c880f0ced8ae450b344de7.tar.gz
gentoo-679bcc3c305c04d2f5c880f0ced8ae450b344de7.tar.bz2
gentoo-679bcc3c305c04d2f5c880f0ced8ae450b344de7.zip
dev-python/jupyter-packaging: Fix testing
Closes: https://bugs.gentoo.org/923053 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild')
-rw-r--r--dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild b/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
index 196ac3deae15..66848c09d16d 100644
--- a/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
+++ b/dev-python/jupyter-packaging/jupyter-packaging-0.12.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,8 +35,13 @@ BDEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # require Internet
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock -o tmp_path_retention_policy=all
+}