summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 07:44:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 08:21:47 +0200
commit5c9c38e226cdffd2d06c79236503e3ae2d76f28a (patch)
treebd0e350e007a3f43bd56f443e205444fab884604 /dev-python/jupyter-ydoc
parentdev-python/jupyter_ydoc: Prepare for rename (diff)
downloadgentoo-5c9c38e226cdffd2d06c79236503e3ae2d76f28a.tar.gz
gentoo-5c9c38e226cdffd2d06c79236503e3ae2d76f28a.tar.bz2
gentoo-5c9c38e226cdffd2d06c79236503e3ae2d76f28a.zip
Rename dev-python/{jupyter_ydoc → jupyter-ydoc}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-ydoc')
-rw-r--r--dev-python/jupyter-ydoc/Manifest1
-rw-r--r--dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch30
-rw-r--r--dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild52
-rw-r--r--dev-python/jupyter-ydoc/metadata.xml13
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/jupyter-ydoc/Manifest b/dev-python/jupyter-ydoc/Manifest
new file mode 100644
index 000000000000..0544517f7a1b
--- /dev/null
+++ b/dev-python/jupyter-ydoc/Manifest
@@ -0,0 +1 @@
+DIST jupyter_ydoc-1.0.0.gh.tar.gz 985632 BLAKE2B 6e4456d3eb96f40e4703d7a1413d62d82497ff46fa15c3e0c6a9dd6544cdbddf5cb5b24d87e135170af643bc45b6b88a0a5f5a3fd03986d85f8428b5f12c4b85 SHA512 7cf8f37fb28ce1b0cf02e5e2db642e6fd5debbf5cb6a119b5291ea2930b177d5f17d7236e105891e828e2c0a4ced3c06cb4e78a1b6c2c318e2674fa5da2a8b8b
diff --git a/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch
new file mode 100644
index 000000000000..2195a0d60e0b
--- /dev/null
+++ b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch
@@ -0,0 +1,30 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 6e0a069..42f76c1 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,12 +2,12 @@
+ # Distributed under the terms of the Modified BSD License.
+
+ [build-system]
+-requires = ["hatchling>=1.10.0", "hatch-nodejs-version"]
++requires = ["hatchling>=1.10.0"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "jupyter-ydoc"
+-dynamic = ["version"]
++version = "1.0.0"
+ description = "Document structures for collaborative editing using Ypy"
+ requires-python = ">=3.7"
+ keywords = ["jupyter", "ypy"]
+@@ -56,10 +56,6 @@ text = "BSD 3-Clause License"
+ Homepage = "https://jupyter.org"
+ Source = "https://github.com/jupyter-server/jupyter_ydoc"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-path = "javascript/package.json"
+-
+ [tool.hatch.build]
+ exclude = ["javascript", "!javascript/package.json"]
+
diff --git a/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild
new file mode 100644
index 000000000000..bd7415f0813d
--- /dev/null
+++ b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="
+ https://github.com/jupyter-server/jupyter_ydoc/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ <dev-python/ypy-websocket-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst-parser dev-python/pydata-sphinx-theme
diff --git a/dev-python/jupyter-ydoc/metadata.xml b/dev-python/jupyter-ydoc/metadata.xml
new file mode 100644
index 000000000000..a7e33c55e1cf
--- /dev/null
+++ b/dev-python/jupyter-ydoc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-ydoc</remote-id>
+ <remote-id type="github">jupyter-server/jupyter_ydoc</remote-id>
+ </upstream>
+</pkgmetadata>