summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:16:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:16:19 -0500
commitd70e08faec77b9abdedf6369c1811615913fcb3c (patch)
treefea79258fa3fef6a72dfb6567716fa9eae90b1e3 /dev-python/keystoneauth/keystoneauth-4.2.1.ebuild
parentapp-crypt/certbot-nginx: 1.8.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-d70e08faec77b9abdedf6369c1811615913fcb3c.tar.gz
gentoo-d70e08faec77b9abdedf6369c1811615913fcb3c.tar.bz2
gentoo-d70e08faec77b9abdedf6369c1811615913fcb3c.zip
dev-python/keystoneauth: 4.2.1 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth/keystoneauth-4.2.1.ebuild')
-rw-r--r--dev-python/keystoneauth/keystoneauth-4.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild b/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild
new file mode 100644
index 000000000000..e1333cf7d22a
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"