summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 19:50:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 20:17:09 +0100
commitede5f45717d42f78fc4d3e90d380ec925cbce150 (patch)
tree48296cfc74721ca453f8cd45711b2dacf030a7f7 /dev-python/keystoneauth1
parentdev-python/txtorcon: Bump to 23.11.0 (diff)
downloadgentoo-ede5f45717d42f78fc4d3e90d380ec925cbce150.tar.gz
gentoo-ede5f45717d42f78fc4d3e90d380ec925cbce150.tar.bz2
gentoo-ede5f45717d42f78fc4d3e90d380ec925cbce150.zip
dev-python/keystoneauth1: Bump to 5.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.4.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index d4fbd09d6211..d137c911bd60 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.3.0.tar.gz 274216 BLAKE2B 873a0bde2507b4b4b2bfc748d77b1c0b8be321c51cff0376020e84a63cebd030b118c90765302ce8cd51467f5c615a9b289480a1105f4d7a4a86e96fe44f7089 SHA512 91a9f9359926932a2e78a9164f8a1f2d08da306cc83f011f9a19535795b6a7faa3af0673665444532893325a2fe752f1d6a18e04b84ea1b3db8c9d1647b4f3cb
+DIST keystoneauth1-5.4.0.tar.gz 275020 BLAKE2B 10ef3799f4f3d06e966816cb6e6802511597e7371f96a75f31abfb2ad33832e90588b466fe0653ab0e7fb6728564e4b056bd208ee08184d7e44a6f230ac1b66f SHA512 874de3a0dded74ca96727b7c0149cdaddf2e3576632e76f84ca4d1810379f9db46ad4139317e36c5815d3340d18e12372bc1c942868c07e9f2800a53356142fc
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.4.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.4.0.ebuild
new file mode 100644
index 000000000000..7a46f3199ebf
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile to test runner name
+ keystoneauth1/tests/unit/test_session.py::SessionTests::test_user_agent
+)
+
+EPYTEST_IGNORE=(
+ # require hacking
+ keystoneauth1/tests/unit/test_hacking_checks.py
+)