summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-21 17:45:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-21 21:31:14 +0200
commit099898f2176a9478d38b48fc624e148cd45b6ec6 (patch)
treeb45ba67aee5b3bef840ea8cb1ca50aebaab48057 /dev-python/lit/lit-10.0.1.ebuild
parentsys-devel/llvm: Bump to 10.0.1 (diff)
downloadgentoo-099898f2176a9478d38b48fc624e148cd45b6ec6.tar.gz
gentoo-099898f2176a9478d38b48fc624e148cd45b6ec6.tar.bz2
gentoo-099898f2176a9478d38b48fc624e148cd45b6ec6.zip
dev-python/lit: Bump to 10.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit/lit-10.0.1.ebuild')
-rw-r--r--dev-python/lit/lit-10.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lit/lit-10.0.1.ebuild b/dev-python/lit/lit-10.0.1.ebuild
new file mode 100644
index 000000000000..4afc13780a0b
--- /dev/null
+++ b/dev-python/lit/lit-10.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}