summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-01 09:24:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-01 09:50:46 +0100
commitc4aeba604387bbd7a73a8dd37367dd7a8bb286dc (patch)
tree17d4cb9deb60a7bb70f8286e67ba1454fb23e096 /dev-python/llfuse
parentdev-python/cftime: Add python@ as co-maint (diff)
downloadgentoo-c4aeba604387bbd7a73a8dd37367dd7a8bb286dc.tar.gz
gentoo-c4aeba604387bbd7a73a8dd37367dd7a8bb286dc.tar.bz2
gentoo-c4aeba604387bbd7a73a8dd37367dd7a8bb286dc.zip
dev-python/llfuse: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.4.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 10b53ddefdf9..83ada0a50e01 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1,2 +1,3 @@
DIST llfuse-1.3.6.tar.bz2 361750 BLAKE2B 74387a6aeb28c3f49234a4f430c3f2aaeefa2057d69e681405d9588c63b3a6e4a6daa58b8996541825c73ff4dabc5607874c2d7885586d793a6436e3f680aec2 SHA512 d67e39daf65c92ebb5bf69abb0c5dc3a88460228b5ec5ee762a11fc909369562411297e8ff9f512ee1ef539d8abec765924be581703fb7e99963c6512cb1f0bd
DIST llfuse-1.4.0.tar.gz 478758 BLAKE2B bec4d6b53936bc79ab4ca8fce7b34d60e39aff6128a186d58caeac68ad135d7d29bbd667cf669e065256e31e257ff4516ff967759d6152672659df0062d03e6d SHA512 8ab92912279a478ba50cf0c151cce3ce1125de27922a97c4da4b3af4ff0714e3a2c5a9e6fd10b87653eb552509491084f018ae3ce4feb7bf952de00a5be3eccc
+DIST llfuse-1.4.1.tar.gz 774540 BLAKE2B f135ff3cde6effe72f5adf1b9ed58566183775ad45acbd1906db1f5c60a38ab74f0c7b6cda949b3ff2c4b46f036c91e16f9231ede1c78359c87758e6abde9ea4 SHA512 e94045018e9d78b7b16355dd499a27694a77a70d61102d05938223b99686e4b9d90b5e14745d92a187ac8e34aa593a12d99bff1baccb19d4236d54eb66ec3e4f
diff --git a/dev-python/llfuse/llfuse-1.4.1.ebuild b/dev-python/llfuse/llfuse-1.4.1.ebuild
new file mode 100644
index 000000000000..4a4e52096272
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://github.com/python-llfuse/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}