summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 22:53:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 23:22:51 +0200
commit3617e004fd5671877112f7daf75a1a9c79a6eb6c (patch)
tree398ee1df351bbee906dc90293fb221b9058f5077 /dev-python/lmdb
parentdev-python/jsondiff: Add python@ as co-maint. (diff)
downloadgentoo-3617e004fd5671877112f7daf75a1a9c79a6eb6c.tar.gz
gentoo-3617e004fd5671877112f7daf75a1a9c79a6eb6c.tar.bz2
gentoo-3617e004fd5671877112f7daf75a1a9c79a6eb6c.zip
dev-python/lmdb: Bump to 1.2.1 (NFC)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lmdb')
-rw-r--r--dev-python/lmdb/Manifest1
-rw-r--r--dev-python/lmdb/lmdb-1.2.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lmdb/Manifest b/dev-python/lmdb/Manifest
index 3de40e454fb5..54ef716ebda5 100644
--- a/dev-python/lmdb/Manifest
+++ b/dev-python/lmdb/Manifest
@@ -1,2 +1,3 @@
DIST lmdb-1.1.1.tar.gz 880359 BLAKE2B b202154eae151d3748e9e90fcb71a3c8a722923c2583e469ef1a0017a4c3dfdfd62d99db24fb79e7da1fc7c6a4fb695d9db5ed6a67750967788a12fe0ba24761 SHA512 4621c87dd646f8ca37f4cdc40ffa2fe809ca4da21b335856e50e6d0ae07f3828d424cde9cc383e4cdc761cd9311eb504d67678a33de51c1931a006ec86a2fcd0
DIST lmdb-1.2.0.tar.gz 881437 BLAKE2B bcb045868c100bcb82daed99bdbd73699dcb5a0e982679f1d9f49747f468e2ab2cbc412ba020b9deca7263fece501c25d984397ee2969187c8118da920c691aa SHA512 75c7aeb3e98ffddb9e40b4eb7404afd3c6ade93753488eac2cb5facfab3ec9b660d925b8bd1c40ca5f8180cb6ca33483020bb4c5ddc074b841693ba278883529
+DIST lmdb-1.2.1.tar.gz 881515 BLAKE2B 76d56e046b5a481411c9a180989da0d1c4b7371058e38abe6d8a6b76f7e2bc62678459241d319850cf739b7b067f3e89d309e5f9a538a187c52c1044fe8b768d SHA512 fa763e24c8f278e0b9c379f39329b7b80051e10d5d8edfdd631486490cfbe5c7bc641d885ffb9f298c0c07f7e6901cc826023c472f98b430a4ec9c0bc71139d5
diff --git a/dev-python/lmdb/lmdb-1.2.1.ebuild b/dev-python/lmdb/lmdb-1.2.1.ebuild
new file mode 100644
index 000000000000..2d0edc21594f
--- /dev/null
+++ b/dev-python/lmdb/lmdb-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Lightning Database"
+HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.28:=
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_compile() {
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
+}
+
+python_test() {
+ epytest tests
+}
+
+python_install() {
+ # This is required when the CFFI extension is used (for PyPy3)
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
+}