summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-04 07:29:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-04 07:44:43 +0200
commit3df7bfceeb8ed5e3adac8df97550d5400c3ecb60 (patch)
tree425b408b8ffdd02f9d285e1bfb0d3527b8de1900 /dev-python/markdown-it-py
parentdev-python/python-ctags3: Bump to 1.6.0 (diff)
downloadgentoo-3df7bfceeb8ed5e3adac8df97550d5400c3ecb60.tar.gz
gentoo-3df7bfceeb8ed5e3adac8df97550d5400c3ecb60.tar.bz2
gentoo-3df7bfceeb8ed5e3adac8df97550d5400c3ecb60.zip
dev-python/markdown-it-py: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown-it-py')
-rw-r--r--dev-python/markdown-it-py/Manifest1
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/Manifest b/dev-python/markdown-it-py/Manifest
index 88b8c49fc5aa..d111c336f99f 100644
--- a/dev-python/markdown-it-py/Manifest
+++ b/dev-python/markdown-it-py/Manifest
@@ -1 +1,2 @@
DIST markdown-it-py-2.2.0.gh.tar.gz 266808 BLAKE2B 8eae5e1924e7afbc79203a11beb7b8271c4c524f5b26cd4bed86f784e4e811d081c2c6bf573bfcdb08f5e270c323957c439c9b9744c7036c4615daece24bde35 SHA512 84d6c15084bf33bdecdcbc8419322f2898bde20de6baeaee6c66c4e6ad9e47dfb8a14e2b1fcf71b8c42e7b61a7caed119919faf0faf6765aad85c186d91fe9d5
+DIST markdown-it-py-3.0.0.gh.tar.gz 275478 BLAKE2B ab264d6de015262e770b5da9c26a48a9fa40209119e38e12e4185aa8b5141986df62f2ff44d80c2d62732e75408b3a70bf35ae9b7ca899ae284636cc62ded710 SHA512 820265595ab650f5ac64419d5c2687d1ee361d2a0550b9d94e86ec826cfe5e89cbd69e59d6582aac41d3b95f00ce4a0b7213bf6cd590fdbd8fd9b743c7418759
diff --git a/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild b/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild
new file mode 100644
index 000000000000..a8af2d10a38b
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-3.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="
+ https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py/
+"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/linkify-it-py-3[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)