summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-29 22:27:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-29 22:29:10 +0300
commitfb2b704bb4bea107d884103ebf678f2d4433546f (patch)
tree6cf9d2d1cf284549428da3b83cc684d331c7fd5e /dev-python/memory_profiler
parentnet-misc/socket-burst-dampener: mark ALLARCHES (diff)
downloadgentoo-fb2b704bb4bea107d884103ebf678f2d4433546f.tar.gz
gentoo-fb2b704bb4bea107d884103ebf678f2d4433546f.tar.bz2
gentoo-fb2b704bb4bea107d884103ebf678f2d4433546f.zip
dev-python/memory_profiler: add 0.58.0, update HOMEPAGE
Closes: https://bugs.gentoo.org/810826 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest1
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.58.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index f3d7f6dc5373..5eabe415abc0 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1 +1,2 @@
DIST memory_profiler-0.57.tar.gz 84096 BLAKE2B d2c5fe810b9ac2f1e52fb8630056ee825d3d56799c15a377bff914be3a04e11c872e557847ef2a107421d082515eb59906f931ad1873ae7fec58fef16caabb4c SHA512 c6e2f755656dc820dfc2cf7a659dc319b3d1aa0df144ac6a08db35f4b38a90a9b994cf9c8320b8370f51c97e0d0bf2f9c4a3ab070b4934879f8e579b732e426a
+DIST memory_profiler-0.58.0.gh.tar.gz 140692 BLAKE2B 2f3917d833dfcc722b61871c7e704e869527a389b10a81b473989b8455630f5defa5f5b21a172708070b89468c7dd66682cd3b9c0bf435e9be49651b69b50137 SHA512 5c02933acffc05f42d2ae98a069d36563e1d26515d439d94ad3903960dd06cd378faae3000b26c022770e71e83db6f770ceaf63cabb92f4159bda0ff9cc4e849
diff --git a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
new file mode 100644
index 000000000000..6103471407d7
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/pythonprofilers/memory_profiler"
+SRC_URI="
+ https://github.com/pythonprofilers/memory_profiler/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+IUSE="examples"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury"
+
+distutils_enable_tests pytest
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop_decorated.py || die
+ ${EPYTHON} -m memory_profiler test/test_mprofile.py || die
+ ${EPYTHON} -m memory_profiler test/test_nested.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+
+ ${EPYTHON} test/test_exception.py || die
+ ${EPYTHON} test/test_exit_code.py || die
+ ${EPYTHON} test/test_global.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_mprof.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+ ${EPYTHON} test/test_stream_unicode.py || die
+ ${EPYTHON} test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}