summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-28 15:33:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-28 15:35:29 +0200
commit75b4ab96f4f5cafaf958319bf884a9f65abe0421 (patch)
tree1a6863b6cc5b4a4a73eafa07c3e88c62b9a5cf1e /dev-python/ml-dtypes
parentdev-python/sybil: Remove old (diff)
downloadgentoo-75b4ab96f4f5cafaf958319bf884a9f65abe0421.tar.gz
gentoo-75b4ab96f4f5cafaf958319bf884a9f65abe0421.tar.bz2
gentoo-75b4ab96f4f5cafaf958319bf884a9f65abe0421.zip
dev-python/ml-dtypes: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ml-dtypes')
-rw-r--r--dev-python/ml-dtypes/Manifest1
-rw-r--r--dev-python/ml-dtypes/ml-dtypes-0.4.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/ml-dtypes/Manifest b/dev-python/ml-dtypes/Manifest
index 7ef493f82991..eb3d041189c8 100644
--- a/dev-python/ml-dtypes/Manifest
+++ b/dev-python/ml-dtypes/Manifest
@@ -1,3 +1,2 @@
DIST eigen-7bf2968fed5f246c0589e1111004cb420fcd7c71.tar.bz2 2239233 BLAKE2B 3a7e81c302cb11ae1d6ef9433a9ec41506c1f37d04cfb8744ac3fcf7dbe9430c1b48d7197ca3b8e1f9354398bac3d0dbc3e0599c0b649acd6175e906befe2973 SHA512 29ee89770726e6e0f5135b7fab24649f3e69223caed90d2daa6f0014783e69fe98f0551de49bd4e393d7b7938f2943caf1ed00f3933fa771ac14fae3c63fd5dd
-DIST ml_dtypes-0.4.0.gh.tar.gz 72894 BLAKE2B a2d70369f8fc72b8234d198ee4517dd3666b6e5a82ea8bca28973966e141426ef5517d441cfdd4cc00146d534194378c191b29f695f1d8c6b9d2785c84d2548c SHA512 a4674c352a641ceab212ff1da25168823d43016dbe00ae06885ef787f1bc0814ae61e595d5f9d43710da29c12e70e3c616e1c634560b911bdb25f4c40b6ba324
DIST ml_dtypes-0.5.0.gh.tar.gz 86170 BLAKE2B a289490fd6d06801965cc72d1abfe4a3b8b48459462bc4ae73a3ace2b4385f26b46081d924c02e1342a18eb98db2df33e3dd77284e40f2357a209a85010071f3 SHA512 20b2677c1e69b9ea298ac7d8ccfee3f0d19b847a805efa183ba04845e1a1697e9030abe00d6e8a4d46981df14c8d5986bcbc3b4e0f36eef2aee1cd04e3996bfe
diff --git a/dev-python/ml-dtypes/ml-dtypes-0.4.0.ebuild b/dev-python/ml-dtypes/ml-dtypes-0.4.0.ebuild
deleted file mode 100644
index ce13d94000fc..000000000000
--- a/dev-python/ml-dtypes/ml-dtypes-0.4.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${PN/-/_}-${PV}
-EIGEN_CommitId="7bf2968fed5f246c0589e1111004cb420fcd7c71"
-
-DESCRIPTION="A stand-alone implementation of several NumPy dtype extensions"
-HOMEPAGE="
- https://github.com/jax-ml/ml_dtypes/
- https://pypi.org/project/ml-dtypes/
-"
-SRC_URI="
- https://github.com/jax-ml/ml_dtypes/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
- https://gitlab.com/libeigen/eigen/-/archive/${EIGEN_CommitId}/eigen-${EIGEN_CommitId}.tar.bz2
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-DEPEND="
- dev-python/numpy:=[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/pybind11[${PYTHON_USEDEP}]
- test? (
- dev-python/absl-py[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- rmdir third_party/eigen || die
- mv "${WORKDIR}/eigen-${EIGEN_CommitId}" third_party/eigen || die
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- mv ml_dtypes/tests . || die
- rm -r ml_dtypes || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- distutils-r1_src_test
-}
-
-python_test() {
- epytest
-}