summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-26 15:47:30 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-26 15:50:35 +0200
commit1e1af105d943e592e50630ba25dd551060c78396 (patch)
treebd0f366ab0af9da644252aa6112736f1c57902e0 /dev-python/moddb
parentsys-libs/glibc: rekeyword 2.38-r13 and 2.39-r4 (diff)
downloadgentoo-1e1af105d943e592e50630ba25dd551060c78396.tar.gz
gentoo-1e1af105d943e592e50630ba25dd551060c78396.tar.bz2
gentoo-1e1af105d943e592e50630ba25dd551060c78396.zip
dev-python/moddb: add 0.11.0
Bug: https://bugs.gentoo.org/921098 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/moddb')
-rw-r--r--dev-python/moddb/Manifest1
-rw-r--r--dev-python/moddb/moddb-0.11.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/moddb/Manifest b/dev-python/moddb/Manifest
index 65d55f95c952..1b7ff8b138eb 100644
--- a/dev-python/moddb/Manifest
+++ b/dev-python/moddb/Manifest
@@ -1 +1,2 @@
DIST moddb-0.10.0.gh.tar.gz 14174575 BLAKE2B cffcdb27d3bd43da412d9ce689ba06d59ee013d4b78b75fddc8749243aaa6abb50c576811ef8e8e88c66ff41b578a79daec4ce0dbe56f444c94eeabedb0fef89 SHA512 5b21aea8a76c2b28579dbb3587956042126b65248684c2c6caef43793b8e7dd1d318434783c252ef191ee7832ea9fe1a434797797a9a76804133a53ede7674f9
+DIST moddb-0.11.0.gh.tar.gz 10528613 BLAKE2B 109c1758362e2655209173d581f1234f15725b8d0b25ed8024ecdfc4da45e30530c87fa9b8a19b556f4cfa60549c38bc552751a39a5dad28f04e58f53d1f484f SHA512 fe064fb7b02553d614477f122013c98257c6fd4d428538681ea97706425480d7fb4a25f49b8673dfba706e33766420c930cee1fae0c93a6b3d2f766b609596ca
diff --git a/dev-python/moddb/moddb-0.11.0.ebuild b/dev-python/moddb/moddb-0.11.0.ebuild
new file mode 100644
index 000000000000..ce605c46602e
--- /dev/null
+++ b/dev-python/moddb/moddb-0.11.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scrapper to access ModDB mods, games and more as objects"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+SRC_URI="https://github.com/ClementJ18/moddb/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Connects to moddb.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests require valid moddb.com login information
+ "tests/test_base.py::TestLogin::test_login"
+ "tests/test_client.py::TestClient::test_get_watched"
+ "tests/test_client.py::TestClient::test_get_updates"
+ "tests/test_client.py::TestClient::test_posts"
+ "tests/test_client.py::TestClient::test_friends"
+ "tests/test_client.py::TestClient::test_messages"
+)
+
+distutils_enable_sphinx docs/source dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ # Dummy moddb.com login information
+ export USERNAME="portage"
+ export SENDER_USERNAME="portage"
+ export PASSWORD="testing"
+ export SENDER_PASSWORD="testing"
+ epytest
+}