summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/numdisplay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/numdisplay')
-rw-r--r--dev-python/numdisplay/Manifest1
-rw-r--r--dev-python/numdisplay/metadata.xml10
-rw-r--r--dev-python/numdisplay/numdisplay-1.6.0-r1.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/numdisplay/Manifest b/dev-python/numdisplay/Manifest
new file mode 100644
index 000000000000..1a47ecc6b49b
--- /dev/null
+++ b/dev-python/numdisplay/Manifest
@@ -0,0 +1 @@
+DIST numdisplay-1.6.0.tar.gz 27397 SHA256 66a702b881aa54f31b7e5e3b7283fd75f8ebd469133e5a3e1943928c82fccc34 SHA512 345aaf360ff8768bd3ddd0b176c4369e38b43f6883a841a7d1cd3d8a15f0f95309c1949126afa0e37bd569371b483b5885923e7048f09a46086d192a3894bfec WHIRLPOOL cef9e62e018b1a19ae4e18380776bd92b21431aeb19516023bece8221052ccaa2244fd7513061c7f9cc43f220eedbcd3a802a175300d8a745fb002761ca4edba
diff --git a/dev-python/numdisplay/metadata.xml b/dev-python/numdisplay/metadata.xml
new file mode 100644
index 000000000000..7a5f1bc18040
--- /dev/null
+++ b/dev-python/numdisplay/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Numdisplay provides the capability to visualize numarray array objects
+ using astronomical image display tools such as DS9 or XIMTOOL
+ directly from the Python command line.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/numdisplay/numdisplay-1.6.0-r1.ebuild b/dev-python/numdisplay/numdisplay-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..c2e398d1c475
--- /dev/null
+++ b/dev-python/numdisplay/numdisplay-1.6.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for interactively displaying FITS arrays"
+HOMEPAGE="http://stsdas.stsci.edu/numdisplay/"
+SRC_URI="http://stsdas.stsci.edu/download/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${D}" -name LICENSE.txt -delete || die
+}