summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 11:45:32 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 11:45:47 +0100
commit1289eded814fa95d7475f5243303330596458a83 (patch)
tree4e190dbd448b86cdb2f332f2a72aa1e80d6b4c93 /dev-python/oauthlib/oauthlib-1.0.3.ebuild
parentdev-python/testresources: Bump (diff)
downloadgentoo-1289eded814fa95d7475f5243303330596458a83.tar.gz
gentoo-1289eded814fa95d7475f5243303330596458a83.tar.bz2
gentoo-1289eded814fa95d7475f5243303330596458a83.zip
dev-python/oauthlib: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/oauthlib/oauthlib-1.0.3.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/oauthlib/oauthlib-1.0.3.ebuild b/dev-python/oauthlib/oauthlib-1.0.3.ebuild
new file mode 100644
index 000000000000..f3c6dcee5ff6
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib https://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) )
+ "
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}