summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 18:36:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 20:30:49 +0200
commite77c9399bc5250ba1259a82d4bc63d1a2605b811 (patch)
tree1378ef328008242e6f8912b9c8bec9597b98a8e1 /dev-python/orderly-set/orderly-set-5.2.3.ebuild
parentdev-python/nanobind: Bump to 2.1.0 (diff)
downloadgentoo-e77c9399bc5250ba1259a82d4bc63d1a2605b811.tar.gz
gentoo-e77c9399bc5250ba1259a82d4bc63d1a2605b811.tar.bz2
gentoo-e77c9399bc5250ba1259a82d4bc63d1a2605b811.zip
dev-python/orderly-set: Bump to 5.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/orderly-set/orderly-set-5.2.3.ebuild')
-rw-r--r--dev-python/orderly-set/orderly-set-5.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/orderly-set/orderly-set-5.2.3.ebuild b/dev-python/orderly-set/orderly-set-5.2.3.ebuild
new file mode 100644
index 000000000000..e8a0d4a9057f
--- /dev/null
+++ b/dev-python/orderly-set/orderly-set-5.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A package containing multiple implementations of Ordered Set"
+HOMEPAGE="
+ https://github.com/seperman/orderly-set/
+ https://pypi.org/project/orderly-set/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditional mypy dep for a test that is not even run
+ # https://github.com/seperman/orderly-set/pull/5
+ sed -i -e '/mypy\.api/d' tests/*.py || die
+}