summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-30 15:57:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-30 16:34:40 -0500
commit853a2cdb3c5c4af1ca6a644be7731ab9647d8530 (patch)
tree9b46625b5c851b43b3177a0707815de6c6dcc3b3 /dev-python/os-xenapi/os-xenapi-0.3.3.ebuild
parentdev-python/microversion-parse: 0.2.1 bump (diff)
downloadgentoo-853a2cdb3c5c4af1ca6a644be7731ab9647d8530.tar.gz
gentoo-853a2cdb3c5c4af1ca6a644be7731ab9647d8530.tar.bz2
gentoo-853a2cdb3c5c4af1ca6a644be7731ab9647d8530.zip
dev-python/os-xenapi: 0.3.3 bump for rocky
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/os-xenapi/os-xenapi-0.3.3.ebuild')
-rw-r--r--dev-python/os-xenapi/os-xenapi-0.3.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/os-xenapi/os-xenapi-0.3.3.ebuild b/dev-python/os-xenapi/os-xenapi-0.3.3.ebuild
new file mode 100644
index 000000000000..bf9fadb4cd64
--- /dev/null
+++ b/dev-python/os-xenapi/os-xenapi-0.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="XenAPI library for OpenStack projects"
+HOMEPAGE="https://github.com/openstack/os-xenapi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}