summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 09:58:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 09:58:36 +0100
commitaa21c19ced71de509941fb6ac1bf7cf329cc7a9e (patch)
treecd76e8d106cf63a209864f665aa1811db676b5e8 /dev-python/packaging
parentdev-python/boto3: Bump to 1.16.63 (diff)
downloadgentoo-aa21c19ced71de509941fb6ac1bf7cf329cc7a9e.tar.gz
gentoo-aa21c19ced71de509941fb6ac1bf7cf329cc7a9e.tar.bz2
gentoo-aa21c19ced71de509941fb6ac1bf7cf329cc7a9e.zip
dev-python/packaging: Bump to 20.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-20.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 2dfc74497551..91ae6efec956 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1,3 @@
DIST packaging-20.7.gh.tar.gz 75182 BLAKE2B f3ba27ec33db576273609f28aabb5edab4acd07d8174c96e3a1608eacdc1a571d2ce96cc4e38c50c964ae5a716bbca077effd6dea039b25ac7bd6ce5707ae08b SHA512 4da8f66af066ac92b47664d21af34a02526cd1639cb766927670bec0ac8c7416116834c847678a29862a46faeda7e2f2393744be315cdfbbb8bd55a04ceb942c
DIST packaging-20.8.gh.tar.gz 76310 BLAKE2B f6a220bf8ed61e4ced5cdb93eac8a83310d5c1abc11861e3eca64ef08e3fa2617a9dedd9006fd833df37da5bd7a33c216fb78b9151b1c72121fbb0a27e7b88d3 SHA512 77c77da9298635274de58b856b8738ab279749f736264212e6ecdeab47db607ea9c6ae696952f0702e9557d1fd2b89c7277a2c81ff55081593f49ebcd6eb74d4
+DIST packaging-20.9.gh.tar.gz 78041 BLAKE2B d87c66aa39cfb832a26a350981722ad40a9193b70ca447030405ee474586cc12e4ae5f4dc7fbc5da6944b717545f3d3f7caac376a3da1ab95aa26429723dc6f6 SHA512 fb71f1036cfaacbe94fdee663af31d6ad1960f73ecc95cba87b461c2d7d2ea90085853bb4682b146492d8c48f784b60ef082e3b1259269857166b143cd9a920b
diff --git a/dev-python/packaging/packaging-20.9.ebuild b/dev-python/packaging/packaging-20.9.ebuild
new file mode 100644
index 000000000000..7b526eafdbd7
--- /dev/null
+++ b/dev-python/packaging/packaging-20.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest --capture=no --strict -vv || die
+}