summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-02 03:44:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-02 04:00:18 +0200
commit4117d837d37a9a4e8ae8ef323db708972f010ea8 (patch)
treea373cf184cd5939928eb23858de8f47c84fc59b4 /dev-python/paste
parentdev-python/plotly: Bump to 5.22.0 (diff)
downloadgentoo-4117d837d37a9a4e8ae8ef323db708972f010ea8.tar.gz
gentoo-4117d837d37a9a4e8ae8ef323db708972f010ea8.tar.bz2
gentoo-4117d837d37a9a4e8ae8ef323db708972f010ea8.zip
dev-python/paste: Bump to 3.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.10.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index c9dc5abd4300..3162c86ac3e2 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,2 +1,3 @@
DIST Paste-3.10.0.tar.gz 651790 BLAKE2B a026f1121a0f6532a6afdd3cb87e0ae16437df0b69dccb900293ee7d1e35a56636bdd0fc379a340b63e400323ee9c728bca608a511d529e5457bba2c08e16deb SHA512 52a6b410564417659cb6f49d6e4b91268386f5e9a82be944b3128a11e37424766d42e9a9f082d682605258a96a57cde113f79c40e32fdaff023a04739c91325b
DIST Paste-3.9.0.tar.gz 637286 BLAKE2B 8bb21f2f6d46750dfff8d9e6377141ea1bcf12848e070138be76823d4dd2bd6be510e420f6568cdab631ab627d45ef93be9815141c6ce31544c4ed38487875e8 SHA512 a9099b89e17f597e853d82cc5d99aaf84fa71ee25e92a382a47a482982800a7e766d8389530ef2a7ad145771ebbabdb1ae5d8370d9cd30121b94e18bcaef3f81
+DIST paste-3.10.1.tar.gz 652629 BLAKE2B a5589027838cbea6f90f919b94edaaba2f26b827cbf911247ec833fa34a5089ffacbc13f8e5369a80e234506e3450818362f1c63cb76e7cf2f619f922f1a965c SHA512 3d224fc017f8354a4737c83d3dcddd0dfa8baaa80a86f843e817ccba295b8e04d16bb10594f17f010da204a0854cf9d57c03a09d0dacb0e7af305a9b0f86422f
diff --git a/dev-python/paste/paste-3.10.1.ebuild b/dev-python/paste/paste-3.10.1.ebuild
new file mode 100644
index 000000000000..8c66dcfb4959
--- /dev/null
+++ b/dev-python/paste/paste-3.10.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/pasteorg/paste/
+ https://pypi.org/project/Paste/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}