summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-30 15:45:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-30 16:56:07 +0200
commitb6d3fbec4a89d5730f8c27905141d05d02e02a38 (patch)
treec1d76e928ad420b26ec2940e37c0c4b5232ff21a /dev-python/paste
parentmedia-radio/tucnak: add 4.43 (diff)
downloadgentoo-b6d3fbec4a89d5730f8c27905141d05d02e02a38.tar.gz
gentoo-b6d3fbec4a89d5730f8c27905141d05d02e02a38.tar.bz2
gentoo-b6d3fbec4a89d5730f8c27905141d05d02e02a38.zip
dev-python/paste: Bump to 3.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.5.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index be44253624ef..9e29d7706989 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.5.2.tar.gz 638207 BLAKE2B 98d9f508923836e41657b653b1cd70d3cea13121dee375c6cfaf28e6f82ebcc36ba74658ade927fd6802f09bf9d9ca566d2b9bbf3eed5122aedd35ed0ac9d5ec SHA512 a1920dbd7ebea137ca33f8f8c33aad563329d1eea193d84e6aa7fc57690f706c1969e3ba76bbf21a73c59a0fe0f732daa4db15705914ac359814b4332a01bc75
+DIST Paste-3.5.3.tar.gz 638791 BLAKE2B 12bcd083ba87699c05c46b1d27757ef4de5f528ba4f01407c113cccc1c59975a6143b6831d1d640b0d0fb82995c7aefd5e14601795403512a2997bd8a9e55466 SHA512 3087ea7b6cc45a90b85c473cbff7f018ca961536ff70fbed4610f86dedc82cef0274ccddb767de411ec2955d0c265cb4e797a14a25697870c38667ccd7c4a2d8
diff --git a/dev-python/paste/paste-3.5.3.ebuild b/dev-python/paste/paste-3.5.3.ebuild
new file mode 100644
index 000000000000..61055d8ef9e6
--- /dev/null
+++ b/dev-python/paste/paste-3.5.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/cdent/paste/
+ https://pypi.org/project/Paste/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-paste
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to cgi deprecation warning
+ tests/test_cgiapp.py::test_form
+ )
+
+ epytest
+}