summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-14 07:36:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-14 07:36:04 +0300
commit8838a2242019fb19c2a5c76cb33e7be8b74dfaa2 (patch)
tree043736b3d7e9b2f930f9ac9f302c1f7c9d2f1125 /dev-python/patch-ng
parentprofiles/default/linux/x86/17.0/musl: unmask systemd-tmpfiles (diff)
downloadgentoo-8838a2242019fb19c2a5c76cb33e7be8b74dfaa2.tar.gz
gentoo-8838a2242019fb19c2a5c76cb33e7be8b74dfaa2.tar.bz2
gentoo-8838a2242019fb19c2a5c76cb33e7be8b74dfaa2.zip
dev-python/patch-ng: enable py3.10, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/patch-ng')
-rw-r--r--dev-python/patch-ng/patch-ng-1.17.4.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/patch-ng/patch-ng-1.17.4.ebuild b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
index ccbdec8387b8..ba2038b565a1 100644
--- a/dev-python/patch-ng/patch-ng-1.17.4.ebuild
+++ b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Library to parse and apply unified diffs, fork of dev-python/patch"
HOMEPAGE="https://github.com/conan-io/python-patch-ng https://pypi.org/project/patch-ng/"
SRC_URI="https://github.com/conan-io/python-patch-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
LICENSE="MIT"
SLOT="0"
@@ -16,8 +17,6 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
distutils_enable_tests unittest
-S="${WORKDIR}/python-${P}"
-
python_test() {
- "${EPYTHON}" -m unittest tests/run_tests.py || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" -m unittest -v tests/run_tests.py || die "Tests failed under ${EPYTHON}"
}