summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-09 16:27:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:25 +0100
commitf3562b69840a493f7be255382d323aebe2027ab6 (patch)
treee0ae2a786787f04974f30a18ad29a6d03f28908d /dev-python/pathlib2/pathlib2-2.3.5.ebuild
parentdev-python/atomicwrites: bump v1.3.0 (diff)
downloadgentoo-f3562b69840a493f7be255382d323aebe2027ab6.tar.gz
gentoo-f3562b69840a493f7be255382d323aebe2027ab6.tar.bz2
gentoo-f3562b69840a493f7be255382d323aebe2027ab6.zip
dev-python/pathlib2: bump v2.3.5
add python3_8 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.5.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.5.ebuild b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
new file mode 100644
index 000000000000..f91dd378eabd
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v || \
+ die "tests failed with ${EPYTHON}"
+}