summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 09:26:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 09:58:05 +0200
commitde0e5747d5a15b0ba2a6fb629dcbc808047f13b4 (patch)
tree723e3655dba764f9136718dc66f87cefd51525d8 /dev-python/pathlib2
parentdev-python/humanize: Bump to 3.10.0 (diff)
downloadgentoo-de0e5747d5a15b0ba2a6fb629dcbc808047f13b4.tar.gz
gentoo-de0e5747d5a15b0ba2a6fb629dcbc808047f13b4.tar.bz2
gentoo-de0e5747d5a15b0ba2a6fb629dcbc808047f13b4.zip
dev-python/pathlib2: Bump to 2.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pathlib2')
-rw-r--r--dev-python/pathlib2/Manifest1
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
index 941e0e976805..bf6172f630c0 100644
--- a/dev-python/pathlib2/Manifest
+++ b/dev-python/pathlib2/Manifest
@@ -1 +1,2 @@
DIST pathlib2-2.3.5.tar.gz 34393 BLAKE2B 7e03214a53f1ebf7718d04f653e24ffa4b06070b0ae21583d98ea0ce956c5aced5ea63bf6062d8e8d979bef4c82137cd2d2d5d6121dc3dda0ae1f713c1868d36 SHA512 3f0f212bf5208d0965ac02a590bef6ac0ec5e3b702828c06c3c9d37119b3db422cc7873de614fdc37ebfb3f52239a6517008d9672a176ca15d03fe13baeeddc8
+DIST pathlib2-2.3.6.tar.gz 38435 BLAKE2B 07a6db61feb56c439e0c4c97d96f87714090628d3971341b64ed253cf9b363b7a3695a665a3def5c2b950cd3dc2ba316ef3dcfaf48f25726fce34afedccdafac SHA512 ed41792338d5808cdd068f6c04021b2918e5376fc6297f163712dec6b00a1f96f7905eeea0a601c333d253e0f1663a0472d842b0d920d680992045bbc36db970
diff --git a/dev-python/pathlib2/pathlib2-2.3.6.ebuild b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
new file mode 100644
index 000000000000..ac123963984c
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v ||
+ die "tests failed with ${EPYTHON}"
+}