summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/peppercorn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/peppercorn')
-rw-r--r--dev-python/peppercorn/Manifest2
-rw-r--r--dev-python/peppercorn/metadata.xml9
-rw-r--r--dev-python/peppercorn/peppercorn-0.4-r1.ebuild40
-rw-r--r--dev-python/peppercorn/peppercorn-0.5.ebuild46
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/peppercorn/Manifest b/dev-python/peppercorn/Manifest
new file mode 100644
index 000000000000..cc6fd2f09ad9
--- /dev/null
+++ b/dev-python/peppercorn/Manifest
@@ -0,0 +1,2 @@
+DIST peppercorn-0.4.tar.gz 18349 SHA256 9a53edd7259a73256519a0d4b23fdc210ea3dfc415e0becdba1d2498cbf7e28a SHA512 b89d36e5c5887f8a21f6bc0d9da33ef0c57a19848dc61fad105bf076eb5214119fb2fa75beeefb936a95e6aa98da7c48ad60596f68da629383820111ef127100 WHIRLPOOL a76793182e65eff1b498f7a872222d427d27a17cae8985fcf1bbb7ab87732f5d4fb6357b94556dd1ac5ea4b4b2d152bfa9864e83e9efaa7879fbf7a01c3dee2a
+DIST peppercorn-0.5.tar.gz 19637 SHA256 921cba5d51fa211e6da0fbd2120b9a98d663422a80f5bb669ad81ffb0909774b SHA512 37f9df282872b0c664780f5e27caf81cc379b05009756cf6c79290b09893d88427f3619916688412dabf20e99f264da8832d959563943e2910b1fcac696edc31 WHIRLPOOL a104c3dca197c5bdd32a9a3f4fafb7c93459cbb8da13f8e581990962ac9afc56c22cdbb101d17271983b61fb0e83f4c0b25590a88d8f54c403110067ea3ba12f
diff --git a/dev-python/peppercorn/metadata.xml b/dev-python/peppercorn/metadata.xml
new file mode 100644
index 000000000000..0d46aa06c986
--- /dev/null
+++ b/dev-python/peppercorn/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">peppercorn</remote-id>
+ <remote-id type="github">Pylons/peppercorn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/peppercorn/peppercorn-0.4-r1.ebuild b/dev-python/peppercorn/peppercorn-0.4-r1.ebuild
new file mode 100644
index 000000000000..f5656f600a0c
--- /dev/null
+++ b/dev-python/peppercorn/peppercorn-0.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting a token stream into a data structure for use in web form posts"
+HOMEPAGE="https://github.com/Pylons/peppercorn http://pypi.python.org/pypi/peppercorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt README.txt COPYRIGHT.txt )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Install only the .rst source, as sphinx processing requires a
+ # theme only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs would
+ # not actually work offline). Install into a "docs" subdirectory
+ # so the reference in the README remains correct.
+ docinto docs
+ dodoc docs/*.rst
+}
diff --git a/dev-python/peppercorn/peppercorn-0.5.ebuild b/dev-python/peppercorn/peppercorn-0.5.ebuild
new file mode 100644
index 000000000000..7d14d3b628b4
--- /dev/null
+++ b/dev-python/peppercorn/peppercorn-0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting a token stream into a data structure for use in web form posts"
+HOMEPAGE="https://github.com/Pylons/peppercorn http://pypi.python.org/pypi/peppercorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it
+DOCS=( CHANGES.txt README.txt COPYRIGHT.txt )
+
+python_prepare_all() {
+ # Fix Sphinx theme. courtesy of Arfrever
+ sed -e "/# Add and use Pylons theme/,+36d" -i docs/conf.py || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}