summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:40:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:54:44 +0100
commit6b30bd97b6d8c774f3d4b27b799495cb3c7c733d (patch)
treef93bc6672ecd079e0045b0dd6b1097c1b979a410 /dev-python/pgspecial
parentdev-python/django: Bump to 4.0.3 (diff)
downloadgentoo-6b30bd97b6d8c774f3d4b27b799495cb3c7c733d.tar.gz
gentoo-6b30bd97b6d8c774f3d4b27b799495cb3c7c733d.tar.bz2
gentoo-6b30bd97b6d8c774f3d4b27b799495cb3c7c733d.zip
dev-python/pgspecial: Bump to 1.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-1.13.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index f361a4ac9992..72487e3c92b0 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1 +1,2 @@
DIST pgspecial-1.13.0.tar.gz 49204 BLAKE2B 7269fc94fc0672db1880ba4b76c8926b6a3c995aac3fca77add7ae6756fcc3295d8d32fcede37cd3fa2d82c82aebfc26d91ed50b4294c5206f04d4c72742b45b SHA512 de2560106fbad14f2095ace468c8490cb325aedb772f649f20a0b5fe65f19afeed33f219d3a6eca683a63b418741a9906a01f7c4bdd8734868517faeba791026
+DIST pgspecial-1.13.1.tar.gz 50269 BLAKE2B 0566a7c2d8ee1ea350e27a4283f56c4cb1360f23ac9fe0147358ff68f527907c47650466dd41ae9c68e8a1f8ba658e452a88db360a7066f5562b7f0c578b8b62 SHA512 4b8f0495451db40087327640edc4bf8c29997b4f501dc5af6d093ad880fc337050d651676ae8ff434da3564e773f9e89e6e7d6bf0d6cfb7b70d8b4beea73a347
diff --git a/dev-python/pgspecial/pgspecial-1.13.1.ebuild b/dev-python/pgspecial/pgspecial-1.13.1.ebuild
new file mode 100644
index 000000000000..6b76fd83565d
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( >=dev-db/postgresql-8.1[server] )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( License.txt README.rst changelog.rst )
+
+src_test() {
+ local db=${T}/pgsql
+
+ initdb --username=postgres -D "${db}" || die
+ # TODO: random port
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U postgres -d postgres \
+ -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U postgres _test_db || die
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}